1. iMore Question's Avatar
    At the top of the All Contacts list my name and number should be displayed. The number is correct, but the name belongs to someone else in the contacts list. This same name is also in 'My Info'. How do I correct this?
    12-13-2015 01:38 PM
  2. Ledsteplin said: Best Answer

    Welcome to iMore! Delete that contact. Then go to Settings > Mail, Contacts and Calendar > Contacts > my info > Tap on your contact. Then after you are set as "me", add the contact back in. Be sure your own contact includes name, number, email, address.
  3. Just_Me_D's Avatar
    Edit the contact via the Mail, Contacts, Calendar settings.
    12-13-2015 01:48 PM
  4. Ledsteplin's Avatar
    Welcome to iMore! Delete that contact. Then go to Settings > Mail, Contacts and Calendar > Contacts > my info > Tap on your contact. Then after you are set as "me", add the contact back in. Be sure your own contact includes name, number, email, address.
    12-13-2015 01:49 PM

Similar Threads

  1. My phone won't send emails. Says password is wrong but it is correct, what can I do?
    By iMore Question in forum General Apple News & Discussion
    Replies: 1
    Last Post: 12-13-2015, 01:56 PM
  2. Replies: 2
    Last Post: 12-13-2015, 09:07 AM
  3. Why is Apple Media Services all of a sudden using so much data?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 12-13-2015, 05:10 AM
  4. Replies: 1
    Last Post: 12-12-2015, 07:13 PM
  5. Replies: 1
    Last Post: 12-12-2015, 06:09 PM
LINK TO POST COPIED TO CLIPBOARD