1. iMore Question's Avatar
    I'm having this problem within seconds of having loaded a route I requested? Was working without any problems in Arizona. I never had an issue, then I moved to Texas. Sometimes it works in the Dallas/Garland area. But often times I can't figure out why it goes blank and has to be initiated from the beginning again only to do the same thing on subsequent tries. Definitely cannot get it to work on longer road trips to College Station. I have an iPhone 4. Att is my carrier.

    I share my talk text plan with someone else. I hesitate to bring it up with this person...could the primary person on the plan be restricting my use and thus affecting my turn by turn navigation use?
    03-06-2015 07:10 AM
  2. Just_Me_D's Avatar
    I doubt it. What iOS version are you running. Is it the native Maps app or AT&T's navigation app? Take it to a nearby Apple Store and have them diagnose the problem for you.
    03-06-2015 07:23 AM

Similar Threads

  1. Why does my power button seem to have a delay when my phone is turned off and on or sleep?
    By slim617 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 3
    Last Post: 03-09-2015, 08:26 AM
  2. Trying to install Viber on my phone. Why isn't it working?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 03-06-2015, 08:38 AM
  3. How do I turn off find my iPhone on my iPhone 5?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 03-06-2015, 08:18 AM
  4. Replies: 2
    Last Post: 03-06-2015, 08:14 AM
  5. Replies: 1
    Last Post: 03-06-2015, 06:39 AM
LINK TO POST COPIED TO CLIPBOARD