1. iMore Question's Avatar
    I have tried in the app store and there are none for my version of mac (10.6.8) - it says the programs are only for 10.7 or higher.
    01-30-2015 01:21 PM
  2. warcraftWidow's Avatar
    The issue is that the Mac AppStore only came out at the tail end of Snow Leopard and then only really so that people could download Lion (10.7). So apps in the AppStore are going to be geared to 10.7 and higher.
    If you can I would suggest upgrading your Mac to lion or higher. Otherwise maybe look at Roxio Toast although I don't know how far back their support goes.
    01-30-2015 01:26 PM

Similar Threads

  1. Why can't I complete the Touch ID setup process?
    By iMore Question in forum Ask a Question
    Replies: 19
    Last Post: 03-27-2017, 02:27 PM
  2. Replies: 1
    Last Post: 01-30-2015, 03:36 PM
  3. Replies: 1
    Last Post: 01-30-2015, 12:36 PM
  4. How to upload a non-square photo to Instagram
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 01-30-2015, 12:12 PM
  5. Major carriers partner to bring LTE to Chicago's subways
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 01-30-2015, 11:51 AM
LINK TO POST COPIED TO CLIPBOARD