1. joemd60's Avatar
    I have Googled this, and nothing worked.
    How come my iMessages are going through to the recipient as my iCloud email?
    And there is no option to set my phone number as default.
    If I uncheck the emails. I get a not delivered, and I have to send it as an SMS.
    The threads I see say to uncheck your emails, that's what causes the sent failure.
    Thanks
    01-09-2015 06:41 AM
  2. SwitchBeach's Avatar
    What device?
    What OS version?
    joemd60 likes this.
    01-09-2015 07:31 AM
  3. Just_Me_D's Avatar
    Go to Settings - Messages - Send & Receive, and then change the selection from your iCloud email address to another one or to your phone number.
    Last edited by JustMe'D; 01-09-2015 at 02:28 PM.
    joemd60 likes this.
    01-09-2015 07:46 AM
  4. joemd60's Avatar
    Sorry for the late reply. Latest OS, 5C.
    01-09-2015 02:25 PM
  5. joemd60's Avatar
    Go to Settings - Messages - Send & Receive, and then change the selection from your iCloud email address to another one or to your phone number.
    I tried that, it did not work. What's even stranger, I unchecked the iCloud email address.
    And when I sent a test text to a number not in my contacts, it went through fine.
    And, it is not every number I text, some work some don't.
    And they're all on IOS, not Android or another OS.
    I am wondering if I should completely wipe the phone.
    Last edited by joemd60; 01-09-2015 at 02:39 PM.
    01-09-2015 02:29 PM
  6. Ledsteplin's Avatar
    I have Googled this, and nothing worked.
    How come my iMessages are going through to the recipient as my iCloud email?
    And there is no option to set my phone number as default.
    If I uncheck the emails. I get a not delivered, and I have to send it as an SMS.
    The threads I see say to uncheck your emails, that's what causes the sent failure.
    Thanks
    My Wife and I both have had that issue. It must be an iOS 8 bug. We did all the resets and reboots. It kept happening. So only thing that works is go to Settings >Messsges>Send and Receive > uncheck ALL email addresses in the top part as well as the bottom. Before iOS 8, this top part to receive messages at could have email checked with no problem as long as the bottom "send from" were not checked. I don't use email for iMessages anyway. So uncheck all email and you should be ok. Also delete all message threads with that address. Both phones. If you're getting "not delivered" try signing out of iMessage, then sign back in. Also Reset Network Settings.
    Name:  ImageUploadedByTapatalk1420834713.144453.jpg
Views: 79354
Size:  113.3 KB


    Sent from my ancient but trustworthy iPhone 5.
    joemd60 likes this.
    01-09-2015 03:18 PM
  7. joemd60's Avatar
    Hopefully the bug gets fixed soon. This only just started to happen yesterday.
    I was only aware of it because my friend asked why I was sending my texts that way.
    As I said, unchecking the emails sometimes throws a wrench in the works.
    That's when I get the undelivered alert.
    Thanks for the replies, much appreciated.
    Last edited by joemd60; 01-09-2015 at 08:57 PM.
    01-09-2015 03:29 PM
  8. zerog46's Avatar
    If that didn't work uncheck iMessage then reboot the device and check it again.
    joemd60 likes this.
    01-09-2015 08:55 PM
  9. joemd60's Avatar
    Funny thing is. This whole thing started when I reset the network settings, to fix another issue.
    So far the phone is behaving, let's hope it continues that way.
    01-09-2015 09:14 PM
  10. norville001's Avatar
    In settings (Messages), turn on iMessage and uncheck all email addresses. It won't permit you to select your phone number but if you back out and return to the same setting, you will see that it automatically selects your phone number.
    09-24-2015 09:21 AM

Similar Threads

  1. Why photos on iMessage disappeare after a while?
    By iMore Question in forum Ask a Question
    Replies: 7
    Last Post: 01-29-2015, 01:27 AM
  2. Replies: 2
    Last Post: 01-14-2015, 12:50 PM
  3. Why does my iPad ask for iMessage sign in every few seconds?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 01-07-2015, 03:14 PM
  4. How can I add an Apple ID for my daughter to use with iMessage?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 01-06-2015, 05:18 PM
  5. Replies: 1
    Last Post: 01-06-2015, 10:52 AM
LINK TO POST COPIED TO CLIPBOARD