1. iMore Question's Avatar
    After updating several machines to Yosemite...I noticed that even though I disable Guest User.....every so often when I restart.....Guest User appears as enabled again. On two machines I disabled it several times, only to have it come back intermittently. Have you any insight into this?

    [redacted]
    Last edited by JustMe'D; 12-16-2014 at 06:23 PM.
    12-16-2014 05:12 PM
  2. Just_Me_D's Avatar
    It has yet to happen on my MacBook, but I'll keep an eye out for it. Thanks for letting us know about the bug. It is appreciated...
    12-17-2014 11:14 AM
  3. KommBEK's Avatar
    Yes!! I do have get this bug occasionally. Feels very hacker-ish to me so it's super annoying. I did 3 clean installation of 10.10.1 and it keeps doing it. Really, OS X built quality as drop substantially since Jobs' gone.

    It's very frustrating to pay over 3K$ for the latest and see your user's experience degraded by an incredible amount of bugs. 3K$+ and you get laughed at by the PC folks when OS X does funny things during a presentation!


    Setup:
    2014 rMBP 15 / GT750M / Yosemite 10.10.1 USB installed / File Vault active on 2 partitions.
    12-23-2014 07:58 PM
  4. KK14's Avatar
    Agree.
    I just bought a MacBook Air - and it may be my last Mac.

    I want my computer to boot to the desktop.
    How can I remove the guest and my profile?
    When I go into User and Groups, I've unlocked so I can make changes - but neither the guest nor my profile will highlight.
    Is there another way to boot straight to the desktop?
    01-07-2015 06:38 PM
  5. warcraftWidow's Avatar
    Agree.
    I just bought a MacBook Air - and it may be my last Mac.

    I want my computer to boot to the desktop.
    How can I remove the guest and my profile?
    When I go into User and Groups, I've unlocked so I can make changes - but neither the guest nor my profile will highlight.
    Is there another way to boot straight to the desktop?
    You can disable the guest option. In Preferences, Users & Groups select the guest user and uncheck the "allow guests to log in" option.

    You cannot delete your user profile. However you may be able to enable automatic login. I don't think this works if you are using File Vault so I can't try it myself. It also may not work if you are using your iCloud credentials to log in. But if you want automatic login you can disable File Vault and create a local password (on your user select Change Password and choose to create a separate password from iCloud).
    To enable automatic login, go to your Security & Privacy preferences and uncheck the box for Disable automatic login. Choose the user to automatically log in as and enter your password. Now you should be set next time you restart your Mac.
    01-07-2015 07:08 PM
  6. KK14's Avatar
    That fixed it - thanks so much.
    01-07-2015 08:02 PM

Similar Threads

  1. Hey! New Mac user here
    By ry4 in forum Introductions
    Replies: 18
    Last Post: 12-29-2014, 05:00 PM
  2. Replies: 0
    Last Post: 12-16-2014, 05:30 AM
  3. Replies: 5
    Last Post: 12-14-2014, 07:55 PM
  4. Replies: 3
    Last Post: 12-13-2014, 03:06 PM
  5. Replies: 2
    Last Post: 12-13-2014, 09:57 AM
LINK TO POST COPIED TO CLIPBOARD