1. cobra302's Avatar
    I downloaded Yosemite this morning, it rebooted, and now it's been stuck with the apple logo on a gray screen with a progress bar not moving for about an hour. Do I let it continue? Is something wrong?
    10-17-2014 11:50 AM
  2. kch50428's Avatar
    Let it go... I've had times when doing an OSX install it seemed like it was going to never finish... it eventually did.
    10-17-2014 12:20 PM
  3. cobra302's Avatar
    Ok was worried maybe something had gone wrong.
    10-17-2014 12:37 PM
  4. kanuj sharma's Avatar
    did it got completed
    10-19-2014 10:25 AM
  5. agarwal.apar's Avatar
    Don't worry, it will complete. It stuck for around 20 mins at 7 mins remaining during installation phase but just relax. Go and grab a cup of coffee and eventually, it will finish
    10-19-2014 11:29 AM
  6. Just_Me_D's Avatar
    Ok was worried maybe something had gone wrong.
    Did the issue get resolved?
    10-19-2014 01:14 PM
  7. meagermind's Avatar
    Same thing here. Stuck on Apple logo for over 2 hours now.

    How long should I wait?
    10-19-2014 04:42 PM
  8. piranhadonna's Avatar
    My mother in laws got stuck on the apple logo and we waited for 12+hrs with no luck. Had to wipe hard drive and install that way.
    10-19-2014 05:40 PM
  9. meagermind's Avatar
    Well, I couldn't wait any longer. I held the power button in to shut down, waited 10 seconds, restarted.

    The Apple logo screen displayed and the the progress bar slowly started progressing. I thought it was going to stall at the same midpoint but instead the logo and progress bar disappeared and thankfully everything proceeded as it should.

    Happy ending.
    10-19-2014 06:22 PM
  10. Scatabrain's Avatar
    This took 4+ hours for me. It is redoing file permissions and rebuilding some structures. It can take a long time.
    10-19-2014 07:57 PM
  11. Mish790's Avatar
    how do i wipe my hard drive and install it that way? i am having the same problem and im very worried right now
    10-20-2014 04:55 AM
  12. pauliwalnuts129's Avatar
    I have been trying to load for 3 days. It took 2 days on my MacBook Air now on MacBook Pro can't get it to load. Turned off and on dozens of times! I'm such an Apple guy, but this is really frustrating!
    10-22-2014 04:25 PM

Similar Threads

  1. Can anyone help with some issues I am having with Yosemite?
    By kingweb in forum OS X Yosemite (10.10)
    Replies: 4
    Last Post: 10-17-2014, 01:29 PM
  2. Does Pages work on Yosemite with the old iCloud system?
    By infty in forum OS X Yosemite (10.10)
    Replies: 2
    Last Post: 10-17-2014, 01:23 PM
  3. iWork on Yosemite
    By SprSynJn in forum OS X Yosemite (10.10)
    Replies: 4
    Last Post: 10-17-2014, 10:58 AM
  4. iMovie for Mac gets dressed up for OS X Yosemite
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-17-2014, 09:30 AM
  5. Why can't I SMS in Messages on Yosemite?
    By MasiMass in forum Ask a Question
    Replies: 2
    Last Post: 10-17-2014, 07:20 AM
LINK TO POST COPIED TO CLIPBOARD