1. iMore Question's Avatar
    What is the oldest version of iTunes that is compatible with IOS8?

    Thank you in advance.
    09-22-2014 09:01 AM
  2. Just_Me_D's Avatar
    I don't know, but I recommend using only the latest version with it...
    09-22-2014 09:14 AM
  3. kch50428's Avatar
    11.3.x might work... 11.4.x is the current release, and you should update to that... ITunes12 will be out with the OSX Yosemite release in a few weeks... And is available to those running the Yosemite beta.
    09-22-2014 09:16 AM
  4. ABrankin's Avatar
    Thank you both for the responses and recommendations. When I got the iPhone 4 I needed to upgrade iTunes and the OS on my older 2006 model Mac, as well as increase the RAM. So before looking at a new iPhone I am trying to determine if I will be able to use iTunes on my existing desktop with the new phone's iOS8. Or if I will need a new desktop as well.

    I will continue to research 11.3.x compatibility with iOS8.
    09-22-2014 09:50 AM
  5. kch50428's Avatar
    For best results, Apple advises using the current release version of iTunes...
    09-22-2014 09:54 AM
  6. warcraftWidow's Avatar
    Unfortunately a 8 year old Mac is due for an upgrade.
    kch50428 likes this.
    09-22-2014 09:55 AM

Similar Threads

  1. My Apps crash since iOS8 upgrade. Why is that?
    By bergman in forum iPad Air
    Replies: 7
    Last Post: 10-07-2014, 12:12 PM
  2. Science Fiction Quiz - Search for TV and Movie Characters
    By Crichton333 in forum iPhone Apps & Games
    Replies: 6
    Last Post: 10-02-2014, 08:58 AM
  3. Replies: 3
    Last Post: 09-22-2014, 09:14 AM
  4. New and updated apps: Jordantron, Calendars, Air Keyboard and more!
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 09-22-2014, 07:40 AM
  5. EE, Vodafone to acquire Phones 4u stores and safeguard hundreds of jobs
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 09-22-2014, 06:12 AM
LINK TO POST COPIED TO CLIPBOARD