1. iMore Question's Avatar
    I have just received new replacement iphone 4s , but icloud backup from previous day on my last iphone and now saying wont accept backup?

    saying ios 7.1.2 required

    no icloud backups compatible with version 7.0.4 ???? what does this mean please?

    thanks
    09-04-2014 10:30 PM
  2. Just_Me_D's Avatar
    Go to Settings - General - Software Update and then update to the latest version. Afterwards, you should be able to restore the backup you attempted to restore earlier. You cannot restore a backup from a newer iOS version to a device running an older version.
    AgentHeracles likes this.
    09-04-2014 10:35 PM

Similar Threads

  1. Replies: 60
    Last Post: 04-01-2007, 08:56 PM
LINK TO POST COPIED TO CLIPBOARD