1. iMore Question's Avatar
    I just got a iPhone5s for Christmas on Boost Mobile's service. I was able to add all of my contacts to my new iPhone5s except 1 contact refuses to submit. I added her to my contact's but when I send her a text message it shows her number instead of her name in the message box, and sending/receiving box. My friend is using a MyTouch Android by SimpleMobile. I have photos below demonstrating this issue.

    Last edited by JustMe'D; 01-05-2014 at 10:28 PM.
    01-05-2014 12:14 AM
  2. rdiddy_25's Avatar
    Not sure what's causing the issue but I would edit your pics, I don't think your friend wants her phone# all over the internet on a public forum. Just my $0.02
    Just_Me_D likes this.
    01-05-2014 01:37 AM
  3. warcraftWidow's Avatar
    Because she's not on an Apple device it is being sent as an SMS not an iMessage. Just showing the phone number is normal in that case I think.
    01-05-2014 09:21 AM
  4. Fausty82's Avatar
    Because she's not on an Apple device it is being sent as an SMS not an iMessage. Just showing the phone number is normal in that case I think.
    The green color of the chat bubbles would be because they are not on iMessage (they may be non-Apple device or just have iMessage turned off for some reason). But the contact name should still show up instead of the phone number.

    From the first screen print, is doesn’t appear that there is a name entered... that would explain the number only showing as the contact information in the Messages app.. but not sure why there’s no contact name in the Contacts app.

    There’s something else going on here...not sure what it is, though.

    Scroll to the bottom of your contact list and see if the entry is listed by phone number... it should be below the 'Z' entries, under the '#' heading. Obvious question: are you sure you entered a contact name in the Contacts app entry?
    01-05-2014 09:34 AM
  5. iEd's Avatar
    Try removing the 1 from the number just use (773)
    01-05-2014 09:54 AM
  6. Jaguarr40's Avatar
    First of all this OP has already stated the following:
    My friend is using a MyTouch Android by SimpleMobile.
    Number 2 it makes no difference if there is a 1 before the area code as long as there is the area code. Number 3 If you are showing the 'V' as an example I believe in order to make it work properly you have to fill in first and last name at minimum. It would not do any good for me to try and duplicate it since both of you have different devices. I would delete you entry and rdiddy is correct I would block out or use a mosiac to hide her number.
    Then just restart your phone and put in all the info for a proper contact nad try again, See what happens then and get back to us. Good luck.

    Lastly my question to you... Are you opening the Contacts app on your phone and hitting the + sign upper right corner to get to the new screen where it should say on your phone at the top "NEW CONTACT" because i do not see ethat anywhere and that is how you should add a proper contact where if you do it this way i am sure you will resolve your issue with Name vs Number when you send a message in this case an SMS since it is green.
    01-05-2014 02:07 PM
  7. napy666's Avatar
    I was able to get in touch with Apple and the guy who helped me said it was something in the Cache settings that caused this issue, because the Cache was acting like it was saving the number instead of the name so it messed it all up for this 1 single contact. So I just erased all the settings on the phone and set it up as a new device and imported all my old contacts via Outlook and re-added this number and that name and number added correctly and my phone is working great! I am able to text my friend fine.
    Jaguarr40 likes this.
    01-05-2014 07:00 PM
  8. Jaguarr40's Avatar
    Glad everything worked out for you.
    01-05-2014 10:14 PM
  9. Just_Me_D's Avatar
    Note: I removed the photos containing the personal phone number.
    rdiddy_25 likes this.
    01-05-2014 10:30 PM

Similar Threads

  1. Viber won't allow me to send messages to people offline
    By iMore Question in forum Ask a Question
    Replies: 4
    Last Post: 01-20-2014, 03:58 PM
  2. Replies: 5
    Last Post: 01-05-2014, 03:57 PM
  3. Replies: 2
    Last Post: 01-04-2014, 11:17 PM
  4. Replies: 1
    Last Post: 01-04-2014, 08:11 PM
LINK TO POST COPIED TO CLIPBOARD