1. iMore Question's Avatar
    Since upgrading my phone, my phone number has disappeared from iMessage on my iPad. How do I re-add it?
    11-19-2013 12:56 PM
  2. Just_Me_D's Avatar
    Logout of iMessage on your iPad, reboot the device and then log back in.
    11-19-2013 01:27 PM
  3. djelkins's Avatar
    Thanks, but that doesn't seem to do it. Any other ideas?
    11-19-2013 02:45 PM
  4. xoayr's Avatar
    Try Resetting Your Network Settings.

    Settings > General > Reset > Reset Network Settings.
    11-19-2013 02:57 PM
  5. Fausty82's Avatar
    Settings > iMessage > Send & Receive > check phone number as well as the email address.
    11-19-2013 03:00 PM
  6. djelkins's Avatar
    I had already tried this earlier, but I just tried this again and it isn't doing anything to help me. Any other thoughts?

    Try Resetting Your Network Settings.

    Settings > General > Reset > Reset Network Settings.
    11-19-2013 03:19 PM
  7. djelkins's Avatar
    That's the issue... my phone number isn't appearing here at all. Is there some other place I need to make certain my number is entered?

    Settings > iMessage > Send & Receive > check phone number as well as the email address.
    11-19-2013 03:21 PM
  8. xoayr's Avatar
    I just was doing some research and realized that since you now have an iPhone, your iPad will only show the email address since your iPhone is now registered as your main iMessage location (since it has a number and it registers your data). I'm guessing you used the same Apple ID?
    11-19-2013 04:39 PM
  9. djelkins's Avatar
    Yes, I'm using the same Apple ID, and I just upgraded from an iPhone 4 to a 5s. Prior to the upgrade, iMessage worked on both my phone & iPad.

    I just was doing some research and realized that since you now have an iPhone, your iPad will only show the email address since your iPhone is now registered as your main iMessage location (since it has a number and it registers your data). I'm guessing you used the same Apple ID?
    11-19-2013 04:47 PM
  10. warcraftWidow's Avatar
    Make sure the number is checked in the settings
    Attachment 42731
    rdiddy_25 likes this.
    11-19-2013 05:03 PM
  11. djelkins's Avatar
    Thanks. This wasn't exactly it, but it led me to notice my Apple ID wasn't appearing in iMessage settings on my phone; just my phone number. Once I entered my Apple ID to also activate my email address, this clued my iPad to add my phone number.

    Thanks all for your very kind and helpful assistance!!!

    Make sure the number is checked in the settings
    Attachment 42731
    11-19-2013 05:15 PM

Similar Threads

  1. [GUIDE] How To Set the Timer to Stop Playing Music in iOS 7.
    By iEd in forum Guides & How-To Articles
    Replies: 8
    Last Post: 11-26-2013, 09:50 PM
  2. Finding new apps in beta
    By rodney0905 in forum iPhone Apps & Games
    Replies: 2
    Last Post: 11-19-2013, 10:07 PM
  3. Replies: 0
    Last Post: 11-19-2013, 10:40 AM
  4. Replies: 0
    Last Post: 11-18-2013, 05:10 PM
LINK TO POST COPIED TO CLIPBOARD