1. Spiritual pilot's Avatar
    Just upgraded to the new Mavericks, And using my iPhone 5 with IOS7 running to send (imessages to people). So I did a check from my desktop iMac using a message to send myself a message, However it tells me my Mobile phone number is invalid and it has to be an American registered/Supported phone number not a landline. Has anybody else had any problems like this, Or could anybody suggest a quick fix. Thank you .below is the message it sends back to me. Thank you for your time and effort if you reply...

    (Uh-oh! That number won't work. Please make sure it's a valid US mobile number from a supported provider, and not a landline. Need help?)
    10-24-2013 09:16 AM
  2. Just_Me_D's Avatar
    After reading your post, I sent myself an iMessage while on my MacBoo running OS X Mavericks. I sent the iMessage to my mobile number (Note: All of my configured devices are set to initiate a conversation using my mobile number). Anyway, as soon as I sent the test message, a second later, the message appeared on my MacBook screen. My iPhone 5 is right next to me on silent mode, but I did not hear it vibrate and the display did not light up. I sent a second test message while keeping my hand on the iPhone 5, and still no "alert" was received. However, when I unlocked it and initiated the iMessage app, both test messages are there and in the same order as on my MacBook. I did not get the invalid phone number error you received. Having said that, go to Settings>Messages>Send & Receive and verify that your phone number is listed and checked under the "You Can Be Reached By Message At" and the "Start New Conversation From" option on your phone. Now on your Mac, go to Messages>Preferences and make sure the information matches what is on your iPhone.
    10-24-2013 10:33 AM
  3. Ipheuria's Avatar
    I used to have a similar problem a little while ago. What I ended up doing to make sure everything was logged in properly was to log out of iMessage on my iPhone. Go to Settings, Messgaes then toggle iMessages off. Once that is done go into the multi-tasking and quit the messages app and shut down the phone. On the Mac go into the Messages app and click Messages, Preferences, click Accounts and then click Sign out. Once that is signed out turn on your iPhone go back into Settings and toggle your iMessage back on then tap Send & Receive and see which number and emails are checked off. On your Mac go into the Messages app and click Messages, Preferences, click Accounts and then click Sign in. It should ask you the numbers and emails you want to use make sure they correspond to your phone.
    10-24-2013 04:41 PM

Similar Threads

  1. Apps refuse to download.
    By toml2003 in forum iOS 7
    Replies: 11
    Last Post: 08-26-2016, 06:41 AM
  2. Help to exit safe mode
    By iMore Question in forum Ask a Question
    Replies: 3
    Last Post: 10-24-2013, 10:23 AM
  3. Rented fIlms bug - anyone else? +how to fix
    By melbsteve in forum Apple TV
    Replies: 2
    Last Post: 10-24-2013, 09:17 AM
  4. Iphone 3gs serial number: XXXXXXX
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 10-24-2013, 05:18 AM
LINK TO POST COPIED TO CLIPBOARD