Home iMore Q&A > Apple Watch

My apple watch 5 is ringing and vibrating but nothing appered on the screen

Asked: Nov 19 2019 | 10:24 am EST 313 Views 4 Answers

Hi dears, I just got my apple watch 5, my first ever watch and I have a question, sorry if this was answered before. If someone calls me, my watch is vibrating and ringing to let me know someone is calling BUT nothing shows on the watch screen unless I click once (push) on the crown. once I push the crown, the call appears on the screen so that I answer or reject the call. Is there anything that I missed here? Any privacy toggles that I should switch off before the caller name or number appear on my apple watch screen by default?


More Answers

1,959
Nov 19 2019 | 12:11 pm EST doogald

These are usually on by default, but do you have raise to wake turned on? (Watch app, General / Wake Screen / Wake Screen on Wrist Raise).

How about Always On Display? (Watch app, Display & Brightness / Always On)
52,866
Nov 19 2019 | 2:41 pm EST Just_Me_D

Hi dears, I just got my apple watch 5, my first ever watch and I have a question, sorry if this was answered before. If someone calls me, my watch is vibrating and ringing to let me know someone is calling BUT nothing shows on the watch screen unless I click once (push) on the crown. once I push the crown, the call appears on the screen so that I answer or reject the call. Is there anything that I missed here? Any privacy toggles that I should switch off before the caller name or number appear on my apple watch screen by default?
If you have the Phone setting on your Apple Watch set to "Mirror my iPhone", go to the Notifications Settings on the iPhone's Settings, scroll down to "Phone" and make sure all three items under the "Alerts" section are checked.
3
Nov 19 2019 | 3:00 pm EST Boudi2019

Thank you so much, I'm new to apple watch, i thought the always on display should be enough so i disabled the raise to wake feature
3
Nov 19 2019 | 3:01 pm EST Boudi2019

Thank you so much, as you said it was the raise to wake feature, i turned off thinking the always on display means the watch will not sleep, i was wrong.