1. bobcozzi's Avatar
    My first Apple watch is the series 3. After a few days I found the Enable Screen Capture toggle switch on the Watch app on my iPhone. I turned it on and it worked great--for a couple days (about 3 or 4 screen captures). Then it completely ignored the key sequence.
    I was on with Apple Support and got the usual "Never heard of this before" response. They actually ended up sending me a replacement watch. Initially out of the box that replacement watch did not recognize the screen capture either.
    I happen to have a 2nd Apple Watch Series 3 with Cellular that I got a a gift. So I tried working with it, it worked right way with screen capture. But then after a couple days, I tried it again and nothing.

    Even with the latest updates to iOS and WatchOS the same issue occurs.
    I went through the normal UnPair and Pair sequence, and that does fix it for a couple days. Then it quits.

    Has anyone else had this issue?
    allenmcohen likes this.
    01-25-2018 06:07 PM
  2. Just_Me_D's Avatar
    I don't know what to tell you. I don't take screenshots with my Watch so I haven't noticed. Hopefully, others who do take frequent screenshots with the Series 3 Watch will reply soon with perhaps a remedy for you.
    01-25-2018 06:33 PM
  3. salscott's Avatar
    Same exact issue....
    01-25-2018 06:34 PM
  4. Lee_Bo's Avatar
    Are you pressing and holding both buttons, or pressing and immediately releasing?
    01-25-2018 09:53 PM
  5. Lee_Bo's Avatar
    I just got my s3 watch last night an so far screen capture is working but I'll post if anything changes.
    02-07-2018 12:27 PM
  6. doogald's Avatar
    3/4 of the time when I try to press both buttons at once for a screenshot, the watch either opens the dock or does whatever a digital crown press would do. Apparently you have to definitively press them both at the same time (without even slightly spinning the crown). I don't need to screenshot much, but I find it pretty frustrating when I try to do it.
    02-07-2018 12:55 PM
  7. Lee_Bo's Avatar
    Just updating. Screen shot successful this morning.
    02-08-2018 08:56 AM
  8. Lee_Bo's Avatar
    @bobcozzi , just checking in. Still happening?
    02-27-2018 10:06 AM
  9. msm0511's Avatar
    TBH mine works too good. Often I'll open Photos on my phone, and there will be a bunch of rando screenshots from my watch.
    04-17-2018 08:06 AM
  10. anon(10000748)'s Avatar
    I’m so glad they finally added that option, on my gen 0 I was constantly taking screen shots on my watch and not on purpose. It was annoying to have to go through and delete all my screenshot pictures.
    05-04-2018 02:15 PM
  11. Annie_M's Avatar
    Ugh... I'm not having any luck taking a screenshot!
    06-26-2018 10:04 AM
  12. Annie_M's Avatar
    OK, so now I'm completely hysterical and embarrassed. I just learned that the reason I wasn't having any luck taking a screenshot was because I hadn't enabled screenshots from the watch app on my iPhone!

    So, for what it's worth, here's a link to "How to take a screenshot on Apple Watch"
    bamf-hacker likes this.
    06-26-2018 10:16 AM

Similar Threads

  1. Used Apple Watch Can't Activate on Verizon
    By renzska in forum Apple Watch
    Replies: 10
    Last Post: 02-21-2018, 03:26 PM
  2. How to preorder the Apple HomePod
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 01-25-2018, 01:30 PM
  3. Fitbit Ionic vs. Fitbit Blaze: Which fitness watch is best for you?
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 01-25-2018, 11:10 AM
  4. How to manage iOS documents and apps using Apple Configurator 2
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 01-25-2018, 10:10 AM
  5. How to add emergency contacts to your iPhone or Apple Watch
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 01-24-2018, 03:10 PM