1. Suggs68's Avatar
    Not sure if its just me, but it doesn't appear that I'm receiving any notifications on my Watch when I have an incoming phone call. I've had several since getting it, and never once have I had any kind of taptic notification or anything else. I checked the settings on the Watch app, and it's set to Show Alerts with both haptic & sound. Is there a setting I'm missing or have others seen this too. Gotten all my other notifications though.
    04-28-2015 01:59 PM
  2. Bigeric23's Avatar
    You might want to try tuning off phone notifications, restarting the watch, and then turning notifications back on.
    04-28-2015 02:34 PM
  3. Suggs68's Avatar
    You might want to try tuning off phone notifications, restarting the watch, and then turning notifications back on.
    Tried that. No go. I'm getting missed call notifications on my watch, but nothing when the call is actually coming in. I have the phone notification settings set to Mirror the iPhone, and I tried both with sound and vibrate on then off. Still nothing.
    04-28-2015 03:07 PM
  4. IIJBII's Avatar
    Not sure if its just me, but it doesn't appear that I'm receiving any notifications on my Watch when I have an incoming phone call. I've had several since getting it, and never once have I had any kind of taptic notification or anything else. I checked the settings on the Watch app, and it's set to Show Alerts with both haptic & sound. Is there a setting I'm missing or have others seen this too. Gotten all my other notifications though.
    Are you using wifi calling by chance? I found that when I have wifi calling on and connected to wifi I won't get the notification that someone is calling. After the call I will get the missed call and voicemail notification.

    I've tested this a few times and it seems that in my case wifi calling is the culprit.

    If this is the same issue you are having I'm thinking it will be addressed in an update.
    04-28-2015 04:02 PM
  5. Suggs68's Avatar
    Are you using wifi calling by chance? I found that when I have wifi calling on and connected to wifi I won't get the notification that someone is calling. After the call I will get the missed call and voicemail notification.

    I've tested this a few times and it seems that in my case wifi calling is the culprit.

    If this is the same issue you are having I'm thinking it will be addressed in an update.
    Interesting. Yes I'm using wifi calling. I'll turn it off and see what it does.
    04-28-2015 04:09 PM
  6. Suggs68's Avatar
    Yep, that was it. I find it still takes a few seconds for the watch to show a call is coming in, which was pretty much instantaneous with my Pebble and Microsoft Band, but turning off the wifi calling did the trick. Thanks for that
    04-28-2015 04:22 PM
  7. IIJBII's Avatar
    Glad I could help! I find the same thing reading how long it take for a call to hit the watch. It's almost at the point where VM picks up. I'm thinking these things will be addressed in an update.
    04-28-2015 07:18 PM
  8. Danny Olivo's Avatar
    I'm not getting my calls of text either. Where do I turn off wifi calling ? And can I do that even if I don't have wifi calling ?
    04-29-2015 01:47 PM

Similar Threads

  1. Replies: 2
    Last Post: 05-02-2015, 11:25 PM
  2. i can't delete the free music off my phone
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 04-27-2015, 11:35 PM
  3. Can I make free call the same way the galaxy does?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 04-27-2015, 06:48 PM
  4. Apple Q2 2015 conference call: Just the highlights!
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 04-27-2015, 05:12 PM
  5. Facebook Messenger adds free video calling for the US and 17 more countries
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 04-27-2015, 02:30 PM
LINK TO POST COPIED TO CLIPBOARD