1. MikeF808's Avatar
    First, let it be known I did not buy the SS model for its cellular feature. I just wanted the stronger sapphire screen. (Big win there, as I’ve already smacked the crap out of it on a door frame and not a single mark.) However, I thought, what the heck? It’s only $10 a month on my AT&T plan. With that said, I’ve now been struggling for 4 days to get it activated. Online chat was no help. They ended up killing my phone’s SIM card in the process. Finally want to physical store. They’re stumped as well. The added line is in my account but every time they go through the activation process, we get an oops, something isn’t quite right error. Tech brought apple in on the conversation and they said it’s definitely an AT&T issue. After much reading, I am now aware this has been a major issue dating back to series 3. The ONLY anomaly we can find is that when I log into my account, the new line shows up as an iPad 9.7 inch. However, on AT&T’s end, it clearly shows up as an Apple Watch. Anyone had a similar issue? If so, what was the fix?
    10-01-2019 09:30 AM
  2. etad putta's Avatar
    Daughter has a series 3 that had been working fine all of a sudden one day she noticed no more cellular connection. Took 3 different tmobile experts to finally get it reactivated. A couple of watch total resets and a couple of hours time. Love the Apple watch but support can be tough. Each group points a finger at the other.
    10-01-2019 09:55 AM
  3. tomc1944's Avatar
    I spent over 6 hours on phone with AT&T before they finally got got my series 5 set up.
    10-04-2019 06:12 AM
  4. o4liberty's Avatar
    Picked mine up at Apple store and they activated mine electronically with T-Mobile with no issue at all. Watch works great very surprised how well it works.
    Lee_Bo likes this.
    10-09-2019 05:35 PM
  5. Lee_Bo's Avatar
    Picked mine up at Apple store and they activated mine electronically with T-Mobile with no issue at all. Watch works great very surprised how well it works.
    Activated mine via the watch app with no issues.

    Very odd indeed.
    10-09-2019 05:51 PM
  6. tcuprof's Avatar
    Activated mine via the watch app with no issues.

    Very odd indeed.
    Same here. I activated my AW4 via the watch app with no issues.
    10-10-2019 02:36 PM
  7. Annie_8plus's Avatar
    I've got an AW3 through AT&T and had no issues setting it up. I'm sorry you're having this trouble! I can't imagine your frustration.
    10-10-2019 02:52 PM
  8. mach1man's Avatar
    I had this issue with my girlfriends lte watch. Mine watch went right through, her wouldn't comes to find out she had to have an att log-in and download the app as well. Plus best buy where we got the watches from messaged something up as well. finally had the right rep on the phone from att and got it resolved
    10-10-2019 03:33 PM
  9. edswife1970's Avatar
    My series 3 was my first cellular watch and I had no trouble at all setting it up with Verizon. Then when I got my series 4 it just transferred over to it.

    Sorry you’re having so much trouble and I hope you resolve it soon!
    10-10-2019 03:36 PM

Similar Threads

  1. Do you want a clear case for your Apple II? Of course you do
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-01-2019, 08:00 AM
  2. Miss Mac’s photo book Printing? There’s an app for that
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-01-2019, 04:40 AM
  3. Record every moment with Vantrue's N2 Pro dual dash cam on sale for $136
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 09-30-2019, 09:30 PM
LINK TO POST COPIED TO CLIPBOARD