1. Coffee4ever's Avatar
    Its been a while now since tvOS11 came out and last week it got an update. Previously when I first installed this tvOS11 update on my two Apple TV4's, I had a lot of problems.

    The main problem was lag and I never had this issue on the previous latest tvOS10.2.2. When I would click on computer on the main home screen, then tv shows, there would be a spinning icon on the screen that sometimes would never stop. I would have to go back to the home screen again.

    Sometimes it does stop but after a long wait. Then when I click on a tv show to play, same thing, spinning icon and long wait. I wonder if its from all the meta data it has to find now with all those episode thumbnails and descriptions. Does anyone else have this trouble of very slow navigation though?

    The other even more annoying problem is how I will be watching a tv show or movie, and it will just go back to the Apple TV home screen in the middle of watching. Then I have to go back and navigate the show I was watching and start over.

    I never had a single issue with tvOS 10.2.2. I did the update this past week to tvOS 11.1 since I thought some of the problems would be solved. It had a bit less lag between menus but still would quit playing during watching something and go back to the home screen.

    I have a large iTunes library on a 10TB HD but never had a issue with tvOS 10.2.2. I even wiped iTunes from my Mac and installed it fresh not carrying over anything From my previous. I even got a new Mac mini. All my apple tv's are connected with ethernet. Same with my Mac iTunes is running on.

    I called Apple once when I first installed tvOS11 but they just said to do the reset and update. I did that but the same problems remain. I've had to keep hooking it to my Mac with a USB-C cable to get it back to 10.2.2.

    I want to use the current tvOS but I feel its still broken. Am I going crazy or are other people having similar issues? I'm not used to being unable to run the current OS's. Especially as security fixes come out like they did this past week. All other devices I have are on the most current OS. iTunes is also on the most up to date version.

    I'm mainly curious if anyone else has had these issues, mainly the one where in the middle of watching something, hot it will go back to the home screen or screen where it shows what home libraries to pick. I don't feel like I have enough info to call apple again. I don't know how much longer apple will keep signing 10.2.2 so I worry I won't be able to go back to a more stable tvOS for long. I've been using Apple TV's since version 2 and never had such problems.

    I should say nothing else I watch will do this and cut out during watching. Like in the youtube app, Netflix, all those work fine. Its just when watching things from my own iTunes library.
    11-05-2017 10:19 AM
  2. Sherry_B's Avatar
    Similar issues here, brand spankin' new Apple TV 4K. The latest update did nothing to fix the dreaded spinner on the screen. When I click on TV it just spins. I could leave it there all day and it would just spin.... all day.
    11-06-2017 10:15 AM
  3. Coffee4ever's Avatar
    Thank you for your reply Sherry, it helps to hear from someone since I feel like its just me and I'm losing my mind. All was fine and is since I set the ATV4 back to 10.2.2, no lag or problems so I know its tvOS 11 to blame. I wonder if it will ever get sorted out. If you can hook to iTunes with a USBC cable, there are 10.2.2 .ipsw files out there apple is still signing thankfully. Then you could go back and all will be well again. There's nothing in tvOS11 I need or want. I just wish this was sorted out in the beta's.
    11-06-2017 11:38 AM
  4. Sherry_B's Avatar
    When we hooked it up the first thing we did was install an update, so I don't even recall what the version was. It was spinning on the TV app after that first update, then the update from the other day didn't improve things at all.

    The first thing I'm going to try is buying a brand new HDMI cable (I'll send hubby to get one) and see if that helps. Hubby snagged one from the basement somewhere, so it's not new but it is 2.0. If a new cable doesn't fix things then I'll look into reverting to 10.2.2.

    I really wanted to watch BlizzCon on my big screen TV this past Friday & Saturday, but I couldn't even get that to mirror or screencast from my iPad or 8 Plus. You know what they say.... if momma ain't happy, ain't nobody happy. I wasn't happy lol.
    11-06-2017 07:47 PM
  5. Coffee4ever's Avatar
    I ordered two new HDMI cables also for both ATV4's but on 10.2.2 things still work fine so don't know why 11.0 and 11.1 don't. My HDTV is old though so I don't think the cable would have much effect. Other friends say they don't have this trouble so not sure why both of mine are. Since 10.2.2 is perfect it has to be something in the update since nothing else has changed here.

    Sorry its happening to you as well and you missed your show. I could still just ignore it and use it at 11.0 or 11.1 but it is hard on my blood pressure and nerves. That's not how I should feel when trying to use a apple device.
    11-07-2017 04:59 PM
  6. Sherry_B's Avatar
    Before hubby went to get another cable this evening, we tried hooking it up in the bedroom upstairs, which is completely set up over WiFi. Everything worked fantastic!! Different HDMI cable, so we're guessing it's either the cable or the receiver. Hubby says he's 99.9% sure it's the cable.

    If you try the new cables and it still doesn't work see if one of your friends (who also has an Apple TV) will let you hook yours up at their house just to test things. This should help you rule out weather its the Apple TV itself or something with your equipment. When we hooked ours up in the bedroom, it just worked as soon as he turned it on. No glitches, slowness, hesitation or anything. You'll know right away if it's the Apple TV with the problem.

    I was able to watch BlizzCon up in my office on my computer. It would of been so much better though on the big screen. I woulda been very upset had I spent all that money on my virtual ticket and not been able to watch lol.
    Coffee4ever likes this.
    11-07-2017 07:01 PM
  7. Coffee4ever's Avatar
    Glad to hear you found a solution. Amazon is really taking their time to send my new HDMI cables. I was frustrated this morning since when I downgraded to 10.2.2 again I forgot to shut off auto update. When I woke up this morning the ATV was on tvOS11 again. So had to downgrade yet again. I never have trouble streaming to it though with the ethernet cable.

    Its just that on 10.2.2 it works perfectly but not on 11.1 or 11.0. So there is some issue with the new OS. I know often it takes a few more beta's and updates before they work out all the bugs in past OS's so I will keep waiting and try again when the next update comes out. Hopefully my new HDMI cables will be here by then.
    11-08-2017 11:28 AM
  8. Coffee4ever's Avatar
    My new current standard HDMI cables came today finally so I used those and some new HDMI settings came up in the video settings area so I guess there was something to do with the cables maybe with the new OS. I got shorter 3' ones this time since my others were I think double the length. I also put it on wifi like you did and all has been well. I might try hooking back to ethernet though and see if that is ok. Thank you for your help through this troubled time. I hope it will continue to be trouble free.
    11-13-2017 09:01 PM

Similar Threads

  1. Apple watch bands prone to dye transfer?
    By ROSES5682 in forum Apple Watch Accessories
    Replies: 3
    Last Post: 11-10-2017, 02:41 PM
  2. How to set up mail, contacts, and calendars on iPhone and iPad
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 11-05-2017, 09:10 AM
  3. Replies: 6
    Last Post: 11-04-2017, 10:02 PM
  4. How to customize the Notes app on iPhone and iPad
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 11-04-2017, 04:10 PM
  5. How to fix the annoying I️ text bug on iPhone and iPad
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 11-04-2017, 02:40 PM
LINK TO POST COPIED TO CLIPBOARD