1. Frost Forged's Avatar
    Over the last 2 months AirPlay has been an unmitigated disaster in my house. Here is the hardware involved:

    1. Apple TV 3rd Generation running latest version
    2. iPhone 6 running iOS 8.1
    3. IPad Air running iOS 8.1

    When attempting to AirPlay from my iPhone or my iPad to AirPlay will show up in Control Center. I will select it, the TV screen will go black, it will try to load and fail. If I restart the iPhone and the Apple TV I can get it to work 50% of the time.

    This is beyond infuriating for my wife and I. We've got a kid on the way and AirPlay is going to get a workout showing pictures to visitors.

    I've tried factory resets. Nothing is working. Do I need to open a port on my router? Does anyone know what I can do to fix this?
    11-14-2014 08:42 PM
  2. BreakingKayfabe's Avatar
    Honestly, whenever I've had AirPlay issues the quick solution has been a hard reboot of whatever iDevice I'm using or the AppleTV itself and it has worked fine.

    What have you done the factory reset on? The ATV itself?
    11-17-2014 07:26 PM
  3. FinancialP's Avatar
    Sounds like a slow or congested router. Reboot it.

    Even though air play is supposed to use Wi-Fi direct now, it still goes through the router first for some reason.
    11-17-2014 10:01 PM
  4. techitrucker's Avatar
    For what is worth I was having Airplay issues in my truck too. Sometimes it would mirror, sometimes only the black screen though video would play and I works get occasional loss of connection from time to time using my ipad as a router and constant disconnects when just trying wifi direct from my iPhone 6. After updating all three devices to 8.1.1 today on the Idevices and the newest firmware on the Apple TV the problems seem to be fixed. Good luck
    11-18-2014 01:46 AM
  5. Frost Forged's Avatar
    Same here. Since 8.1.1 all of my AirPlay issues have gone away. Not sure why I was having issues and others weren't but I'm glad its good now. Thanks for the help everyone.
    12-03-2014 09:19 PM
  6. knotsure's Avatar
    I have been having problems with AirPlay and my ip6+. When mirroring on my Apple TV I can view photos , videos, and time lapse videos. I am not having any luck viewing slo mo videos . It just goes black and does nothing. I am also experiencing lag when viewing videos. Is the Apple TV hardware having a hard time keeping up with the new iPhone or what????
    01-07-2015 07:29 PM

Similar Threads

  1. Apple Watch sighting
    By gtg465x in forum Apple Watch
    Replies: 7
    Last Post: 04-21-2015, 10:31 AM
  2. Why are my settings and other Apple apps as well as Cydia deleted after respring?
    By Deklan Greenwood in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 2
    Last Post: 11-15-2014, 03:30 PM
  3. Replies: 1
    Last Post: 11-14-2014, 07:58 PM
  4. Having issues with app permission popups in iOS 8? Here's the fix!
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 11-14-2014, 03:12 PM
  5. Replies: 1
    Last Post: 11-14-2014, 02:44 PM
LINK TO POST COPIED TO CLIPBOARD