1. fopa138's Avatar
    I ve been having a problem with my apple tv home sharing with my mac. The setting on my mac and apple tv are both on, but the apple tv wont connect. I have the latest itunes, no firewall..This happens every time I want to use my apple tv after its been sleeping for a while.. The way I get it to work is i turn off home sharing on my mac, then turn on. Apple tv then connects. I really dont think i need to do this every time i want to watch apple tv...


    Anyone else with similar issues..
    10-22-2010 08:18 AM
  2. Rene Ritchie's Avatar
    I haven't had that issue but I'll look into it and get back to you. Apple TV shouldn't "forget" the sharing just because it sleeps.
    10-23-2010 12:44 PM
  3. Gorflin's Avatar
    I have exactly the same problem, my Apple TV and iPad both lose connection with my Windows iTunes library. My iPad still connects to my TV though.
    10-23-2010 09:28 PM
  4. andrewfy's Avatar
    I am sorry for cann't help you!
    10-26-2010 01:51 AM
  5. mfares's Avatar
    I had this issue befor and I fix it by removing the security on your wireless router .. mine was security enabled wireless network but when i remove it so far it never disconnect for weeks now and my itunes library I share are 1+ TB

    I hope this help
    10-26-2010 02:45 AM
  6. TampaDude's Avatar
    I had this issue befor and I fix it by removing the security on your wireless router .. mine was security enabled wireless network but when i remove it so far it never disconnect for weeks now and my itunes library I share are 1+ TB

    I hope this help
    Removing the security on your wireless router is a really bad idea. There must be a better way.
    10-26-2010 01:56 PM
  7. andrewfy's Avatar
    I always want to buy an apple TV, but i didn't know anything about it!
    10-26-2010 10:46 PM
  8. Ipheuria's Avatar
    Removing the security on your wireless router is a really bad idea. There must be a better way.
    I agree the whole idea of the router is so the connection is more secure. I think the OP said no firewall meaning there is no router? I'm not sure. OP try resetting your router? how close is your router to your devices? PM me if you want I had a problem with the proximity of my router and my iDevices.
    11-01-2010 04:40 PM
  9. macharborguy's Avatar
    okay, i just fixed my home sharing / remote app issues with my Windows-based iTunes share.


    I am running Windows 7 64bit.

    Go to the Windows/Start Menu, type "Windows Firewall With Advanced Security" into the search box. Launch that app.

    On the resulting window, click on "Inbound Rules" in the left sidebar, then in the center area look for the entries titled "Bonjour Services". Double click on each of them and in the resulting windows click on the Advanced tabs.

    From there, there are 3 checkboxes. Domain, Private and Public. Make sure Private is checked in both windows. Click apply.

    Doing this made all of my iDevices remote apps immediately see my Windows7 iTunes library.
    11-02-2010 12:11 PM
LINK TO POST COPIED TO CLIPBOARD