1. ridiculocity's Avatar
    Across both me and my partners devices tonight iTunes is running like a snail. It's not our wifi cause everything else is normal.

    Anybody else experiencing slugging AppStore load times for installing, page views, reviews??

    Btw I'm in Australia
    04-12-2013 08:02 AM
  2. Just_Me_D's Avatar
    The App Store appear to be functioning normally on my device.
    04-12-2013 09:32 AM
  3. Laelipoo's Avatar
    it wasn't loading for me but killing it in the task switcher and relaunching the app store worked for me.
    04-12-2013 10:05 AM
  4. ridiculocity's Avatar
    After a few hours for me it started working could have been a delta update goin on
    04-12-2013 09:49 PM
  5. rdiddy_25's Avatar
    I haven't been able to dl anything all day. Resprings, reboots and nothing. Idk what's up
    04-12-2013 09:53 PM

Similar Threads

  1. 3GS very slow after 4.0 jailbreak
    By Jimbos Jumbos in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 8
    Last Post: 07-19-2010, 07:17 AM
  2. 3gs running super slow
    By white573 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 3
    Last Post: 07-14-2010, 10:34 AM
  3. iPhone runs very slowly
    By MntnDewMan in forum iPhone 4
    Replies: 15
    Last Post: 06-16-2010, 11:34 AM
  4. iphone 2g very slow, almost frozen
    By humanmusic in forum iPhone 4
    Replies: 11
    Last Post: 04-18-2010, 10:55 PM
  5. 3G accelorometer very slow!
    By grant#IM in forum iPhone 4
    Replies: 7
    Last Post: 07-10-2009, 09:41 AM
LINK TO POST COPIED TO CLIPBOARD