Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Thread AuthorThread Author   #1  
    mohawk apple's Avatar
    iMore Beginner

    Posts
    51 Posts
    Global Posts
    660 Global Posts
    iOS Version
    ios 6

    Default not receiving imassages on macbook / iPad only iPhone?

    but i can send iMessages on them,but for sum reason i'm not receiving them.
    BLACK/SLATE 64GB
  2. #2  
    Karenkcoulter's Avatar

    Posts
    5,564 Posts
    Global Posts
    5,569 Global Posts
    iOS Version
    iOS 6.1.3

    Default not receiving imassages on macbook / iPad only iPhone?

    I wish my macBook would give imassages :-)

    It should work between all devices. Check that they have the same phone numbers or email addresses.
  3. #3  
    JustMe'D's Avatar

    Posts
    19,051 Posts
    Global Posts
    19,279 Global Posts
    iOS Version
    7.0.4

    Default not receiving imassages on macbook / iPad only iPhone?

    First of all, is your MacBook's iMessage app running in the background? Now go the Messages menu and select "My Status" and make sure you are NOT offline and that it shows you listed as "available". Now, scroll up and go to "Preferences" and then select "accounts". Select your Apple ID and then check to see if your iPhone mobile phone number is listed. If not, you need to add your Apple ID to your iPhone in the Messages settings. Afterwards, your phone number will show up in the settings on your MacBook and then you should be good to go.
    If everything checks out okay, just reboot all of your devices and see if that clears it up for you.


    Just Me, D
    Thanked by:
    mohawk apple (10-26-2012)
  4. Thread AuthorThread Author   #4  
    mohawk apple's Avatar
    iMore Beginner

    Posts
    51 Posts
    Global Posts
    660 Global Posts
    iOS Version
    ios 6

    Default Re: not receiving imassages on macbook / iPad only iPhone?

    Quote Originally Posted by JustMe'D View Post
    First of all, is your MacBook's iMessage app running in the background? Now go the Messages menu and select "My Status" and make sure you are NOT offline and that it shows you listed as "available". Now, scroll up and go to "Preferences" and then select "accounts". Select your Apple ID and then check to see if your iPhone mobile phone number is listed. If not, you need to add your Apple ID to your iPhone in the Messages settings. Afterwards, your phone number will show up in the settings on your MacBook and then you should be good to go.
    If everything checks out okay, just reboot all of your devices and see if that clears it up for you.


    Just Me, D
    thanks that worked! up and running again
    BLACK/SLATE 64GB
  5. #5  
    JustMe'D's Avatar

    Posts
    19,051 Posts
    Global Posts
    19,279 Global Posts
    iOS Version
    7.0.4

    Default not receiving imassages on macbook / iPad only iPhone?

    Quote Originally Posted by mohawk apple View Post
    thanks that worked! up and running again
    You are very welcome, my friend. Take care and have a great weekend.



    Just Me, D

Similar Threads

  1. Music not in iTunes on MacBook
    By johnny football hero in forum iTunes
    Replies: 3
    Last Post: 01-29-2012, 06:38 AM
  2. Iphone 4 can receive but not send email on wifi
    By voltaire in forum iPhone 4
    Replies: 4
    Last Post: 10-14-2011, 09:32 PM
  3. Watch Flash content and Hulu (not plus) on iPad or iPhone.
    By hermdog in forum iPhone Apps & Games
    Replies: 0
    Last Post: 02-23-2011, 10:18 PM
  4. Replies: 5
    Last Post: 08-05-2010, 09:27 AM
  5. AOL Email on iPhone 4-Can send but not receive
    By RIPNHL2005 in forum iPhone 4
    Replies: 2
    Last Post: 07-21-2010, 10:43 AM

Posting Permissions