Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By Mikah Sargent
  1. Thread AuthorThread Author   #1  
    scubabs's Avatar
    iMore Nanite

    Posts
    2 Posts

    Default messaged between iphone 7+ and Imac not syncing all messages

    OK, in El Cap when I had all the correct settings (essentially everything on for messages between phone and Mac,ipads etc) when I opened Messages on my iMac, all of the conversations that I had my iphone would show up.

    I upgraded to Sierra last night. Added the appropriate accounts to Messages on my iMac and ensured forwarding and iMac was selected from my iPhone, but NONE of my conversations on my iphone 7+ are visible on my Messages on my iMac.

    Any thoughts?
  2. #2  
    Mikah Sargent's Avatar
    Senior Editor, iMore

    Posts
    17 Posts

    Default Re: messaged between iphone 7+ and Imac not syncing all messages

    Hiya, scubabs!

    Are you talking about older conversations that already existed in Messages, or new ones? After you've connected accounts, you should be able to see conversations pop up on both your Mac and your iPhone, but conversations that took place before you connected your account aren't going to show up — even after you've logged in.

    With just a little more information, I might be able to help you troubleshoot the issue! Let me know.
  3. Thread AuthorThread Author   #3  
    scubabs's Avatar
    iMore Nanite

    Posts
    2 Posts

    Default Re: messaged between iphone 7+ and Imac not syncing all messages

    Hi Mikah,
    Yes I'm talking about older conversations that already exist in messages in my iPhone. Previously when I have linked an account in my Mac they have populated in the mac message program. You are saying that doesn't happen, but it used to. In other version than Sierra it would take a few minutes but all the old phone conversations would push over.

    Thanks for your reply.


    Quote Originally Posted by Mikah Sargent View Post
    Hiya, scubabs!

    Are you talking about older conversations that already existed in Messages, or new ones? After you've connected accounts, you should be able to see conversations pop up on both your Mac and your iPhone, but conversations that took place before you connected your account aren't going to show up even after you've logged in.

    With just a little more information, I might be able to help you troubleshoot the issue! Let me know.
  4. #4  
    Mikah Sargent's Avatar
    Senior Editor, iMore

    Posts
    17 Posts

    Default Re: messaged between iphone 7+ and Imac not syncing all messages

    Alrighty, here's something you might try:

    1. Make sure you're logged in to your Apple ID on your Mac and you've got iCloud turned on.
    2. Open up System Preferences.
    3. Click iCloud.
    4. Click Options... next to iCloud Drive.
    5. Scroll down until you find Messages.app in the list.
    6. If it's not checked, check it and click Done.
    7. If it is checked, uncheck it, click Done and then repeat steps 4-6.

    Hopefully you can force the Mac to sync up with iCloud and grab all your Messages off the server.

    Hope this works for you!
    Greg Chard likes this.
  5. #5  
    Greg Chard's Avatar
    iMore Nanite

    Posts
    1 Posts

    Default Re: messaged between iphone 7+ and Imac not syncing all messages

    Im having same issue (but with iPhone 6. And when i attempted to follow your instructions, after clicking on "options" beside "iCloud Drive" there was not an option for messages (to click and unclick as you stated). Thoughts?

    So, just to be clear, prior to Sierra, all my texts would connect from my mac to my phone, but now not happening. Now, i cant even send a text to people in my contacts (other than iphone users) from my mac, inside messages.
  6. #6  
    rdstryr's Avatar
    iMore Intermediate

    Posts
    173 Posts

    Default Re: messaged between iphone 7+ and Imac not syncing all messages

    This happened to me after initially upgrading to Sierra. I turned off text forwarding on iPhone and turned it back on and it worked after that. Also make sure that your phone number is checked under preferences on the Mac.
  7. #7  
    ItnStln511's Avatar
    iMore Intermediate

    Posts
    443 Posts

    Default Re: messaged between iphone 7+ and Imac not syncing all messages

    Quote Originally Posted by Mikah Sargent View Post
    Alrighty, here's something you might try:

    1. Make sure you're logged in to your Apple ID on your Mac and you've got iCloud turned on.
    2. Open up System Preferences.
    3. Click iCloud.
    4. Click Options... next to iCloud Drive.
    5. Scroll down until you find Messages.app in the list.
    6. If it's not checked, check it and click Done.
    7. If it is checked, uncheck it, click Done and then repeat steps 4-6.

    Hopefully you can force the Mac to sync up with iCloud and grab all your Messages off the server.

    Hope this works for you!
    I don't have "messages.app" under iCloud Drive options. Any advice?
  8. #8  
    rdstryr's Avatar
    iMore Intermediate

    Posts
    173 Posts

    Default Re: messaged between iphone 7+ and Imac not syncing all messages

    You can also try logging out of iCloud on both the Mac and iPhone, turn off text forwarding, and then restart both devices. Make sure you select the option to keep a copy of the contact, keychain, etc. on the devices when it ask you. When they are restarted sign back in to iCloud and turn text forwarding back on, enter auth code and try it again.

    Yes it will sync up old messages as long as they are still on your phone.

Similar Threads

  1. Replies: 2
    Last Post: 10-12-2016, 01:58 PM
  2. Replies: 1
    Last Post: 09-28-2016, 08:26 PM
  3. The best Apple TV controllers, mounts, speakers, and more
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 09-28-2016, 02:12 PM
  4. Replies: 0
    Last Post: 09-28-2016, 02:00 PM

Posting Permissions