1. eastbayrae's Avatar
    How so I shut this off when on battery? I just got an MBA yesterday.


    Sent from my iPhone using Tapatalk 2 while driving in reverse
    07-31-2013 07:06 AM
  2. Shanicenicolle's Avatar
    ___
    Last edited by Shanicenicolle; 07-31-2013 at 08:20 AM.
    07-31-2013 07:17 AM
  3. eastbayrae's Avatar
    It's relevant in that it is the hardware I am having an issue with. When on battery the wifi shuts off when the screen goes dark.


    Sent from my iPhone using Tapatalk 2 while driving in reverse
    07-31-2013 07:44 AM
  4. Massie's Avatar
    System Preferences. See directions here under the Sleep section: Mac Basics: Set your preferences
    07-31-2013 07:51 AM
  5. Shanicenicolle's Avatar
    Lmao I automatically thought masters in business admin. Too early. My apologies
    07-31-2013 08:19 AM
  6. tigerinexile's Avatar
    The threads about Airs are very amusing if one thinks that people are talking about MBA degree programs.

    (Me, I'm finishing up an MBA, and I bought an MBA to deal with my final year of classwork...)
    Shanicenicolle likes this.
    07-31-2013 03:21 PM
  7. TurboTiger's Avatar
    I have an MBA but I don't have an MBA

    Good Luck
    07-31-2013 09:31 PM
  8. eastbayrae's Avatar
    Well I don't want the screen on all day. I tried NoSleep and it doesn't work. As soon as the screen goes dark the wifi shuts off. So anything I am downloading stops.
    08-01-2013 09:08 AM
  9. Massie's Avatar
    Maybe try looking into InsomniaX.

    Other ideas: do you have the same issue if you just put up a screensaver? Or crank the backlight way down? Or if you have an external monitor you could in theory use Clamshell Mode.

    Good luck!
    08-01-2013 06:29 PM
  10. warcraftWidow's Avatar
    Well I don't want the screen on all day. I tried NoSleep and it doesn't work. As soon as the screen goes dark the wifi shuts off. So anything I am downloading stops.
    NiSleep worked for me. Did you have the network activity add on (in app purchase)?

    Or just go into Energy Saving in Preferences and set the computer sleep to never and display sleep to x minutes.
    08-02-2013 06:47 AM
  11. eastbayrae's Avatar
    NiSleep worked for me. Did you have the network activity add on (in app purchase)?

    Or just go into Energy Saving in Preferences and set the computer sleep to never and display sleep to x minutes.
    I am using NoSleep now and it is very spotty as to if it's going to work or not. I had a chat with Apple and they said due to the special design of the MBA hardware that there is noway to keep the wifi running when it is on battery and the screen is off. It is in sleep mode at that point. The CSR told me this is not an issue in the MBP, which I will be looking at getting when Apple does the Haswell refresh in October.
    08-03-2013 05:41 AM
  12. Massie's Avatar
    Interesting, I was wondering why I didn't recognize this issue from my MBP.
    08-03-2013 06:01 AM
  13. warcraftWidow's Avatar
    Interesting, I was wondering why I didn't recognize this issue from my MBP.
    Agreed. It worked for my MBP retina as well.
    08-03-2013 12:39 PM
  14. LVMHgirl's Avatar
    Hmmm. I just replaced my MBP with an MBA over the weekend. Haven't noticed the wifi disconnecting during sleep mode yet but wow, good to know. Thanks.
    08-15-2013 04:18 AM
  15. rjkgr's Avatar
    i turned off my sleep mode but it still goes on sleep! haha how?
    09-06-2013 04:53 PM

Similar Threads

  1. Replies: 9
    Last Post: 08-15-2014, 06:41 PM
  2. Sleep/wake button
    By jwsnj3rd in forum iPhone 4S
    Replies: 16
    Last Post: 11-23-2013, 09:33 PM
  3. Sleep Shortcut
    By rosenstar in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 2
    Last Post: 07-22-2013, 06:20 PM
  4. [GUIDE] How to Put Device in DFU Mode and Restore it
    By rdiddy_25 in forum Guides & How-To Articles
    Replies: 0
    Last Post: 07-10-2013, 11:23 AM
LINK TO POST COPIED TO CLIPBOARD