Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    maurinho217's Avatar
    iMore Nanite

    2 Posts

    Default Airport express 2nd generation problem - dropping speed

    Hey guys.

    I got an airport express connected to a 20mb fiber Internet. I was using it already, so I did a factory reset and setup as new.

    But it is dropping the connection speed constantly, usually in my bedroom I get 17 to 18mb ( the router is in my office, next to my room), but sometimes during the day all I can get is 5 to 6 mb. It is not a Internet problem, because when I connect the Ethernet cable on my MBP, it works flawlessly, reaching 20mb or even more, with no drops.

    I have a guest network, but I already tried to turn it off, but the speed keeps dropping.

    I already changed the channels from automatic to channels that no one near me is using ( via iStumble, I think).

    There are no more than 6 devices connected at the same time on my network, and there are times that I get full speed with all devices connected, and get a crappy speed connection with just my iPhone connected to it.

    If someone got an idea please let me know, I am about to buy from another brand, because this pissing me off.

    TL;DR: airport express not working properly,keeps dropping my connection speed , did a factory reset and all that I can imagine and found here, but it keeps slowing it down ( cabled connection works fine).


    Sent from my iPhone using Tapatalk
  2. #2  
    Bigeric23's Avatar
    iMore Genius

    3,636 Posts
    Global Posts
    3,647 Global Posts

    Default Re: Airport express 2nd generation problem - dropping speed

    So . . . it's not dropping your connection, ever? Have you tried to relocate it to a different location?
  3. #3  
    bobmavric's Avatar
    iMore Nanite

    2 Posts

    Default Re: Airport express 2nd generation problem - dropping speed

    I have the same problem. I use it as extender in my room but I have no idea why it uses 802.11g instead of N while my Time Capsule and AirPort Extreme use N channel. This causes very low speed. As I checked, it takes 35 minutes to copy a 2Gb file from my Mac Pro to external hard drive connected to Time Capsule, while it takes 4 minutes only when I remove Airport Express from the network.

Similar Threads

  1. Can't download apps ! AppStore PROBLEM ???
    By Daniel Gabriel in forum iPhone 5s
    Replies: 14
    Last Post: 07-21-2016, 03:02 AM
  2. Replies: 2
    Last Post: 09-01-2015, 08:37 AM
  3. Plants vs Zombies 2 problem
    By GSM-S in forum Ask a Question
    Replies: 1
    Last Post: 08-27-2015, 05:07 PM
  4. Apple Stores drop Smart Signs, start selling third-party watch accessories
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 08-26-2015, 02:12 PM
  5. Replies: 1
    Last Post: 08-26-2015, 07:18 AM

Posting Permissions