Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    victoria20131's Avatar
    iMore Nanite

    1 Posts

    Default Please help me with 3GS!!


    I am new to this forum so hope I am posting in right place....and praying that you guys can help me.

    My beloved 3GS died on me today...RIP

    However, I do have a *spare* 3GS ..sigh of relief. This phone was jailbroken and happily working perfectly until my clever friend pressed restore...oops! It was stuck on activation screen and I didnt have time or brains to be honest to try to fix so I took it to a sort of phone stall. He fixed it - i.e it turned on etc. However, it now runs on older version 4.1 but when it was *bricked* it was running 5. something.

    Anyway, I am desperate for viber as I live abroad and it is only way I can keep in daily contact with family etc and when I try to download I am given an error message of requires ios 4.3
    is there any way İ can update-re jailbreak so I can get this app???? I have red snow not sure what version on my computer but have not got a clue how to go about it?

    I wont be able to get a new iphone for a few months so really hoping I wont be stuck viber-less!

    Any help much appreciated.


  2. #2  
    kch50428's Avatar
    iMore Genius

    20,842 Posts
    Global Posts
    21,723 Global Posts

    Default Re: Please help me with 3GS!!

    Moderator note: headline/post subject edited to reflect nature of needed help...
  3. #3  
    natasftw's Avatar
    iMore Specialist

    1,356 Posts
    Global Posts
    1,359 Global Posts

    Default Re: Please help me with 3GS!!

    If it was jailbroken on iOS5+, I'd be willing to wager you have SHSH blobs saved on Cydia's servers.

    Download the latest version of redsn0w. Choose Extras, SHSH Blobs, Query. See which set of blobs Cydia has saved for you.

    You'll want to choose something between 5.x and 6.0.x. Those are the ranges you can upgrade to with redsn0w support. Head over to iclarified.com and download the ipsw for the version you have blobs for and use redsnow to manually restore to that ipsw. You should be able to jailbreak easily from there.

Similar Threads

  1. Replies: 5
    Last Post: 07-29-2013, 02:03 AM
  2. Help with siri
    By anon7759143 in forum Siri
    Replies: 7
    Last Post: 07-27-2013, 09:44 AM
  3. Replies: 13
    Last Post: 07-25-2013, 04:26 PM
  4. HELP WITH IOS 7 Updating
    By Diego Acosta1 in forum iPhone 4S
    Replies: 9
    Last Post: 07-25-2013, 03:30 AM
  5. Help please, phone is stuck in recovery :(
    By itsaykj in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 4
    Last Post: 07-24-2013, 08:06 PM

Posting Permissions