Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 17 of 17
Like Tree1Likes
  • 1 Post By 3cit
  1. Thread AuthorThread Author   #1  
    KBV1's Avatar
    iPhone Newbie

    Posts
    24 Posts
    Global Posts
    318 Global Posts
    iOS Version
    5.1.1

    Default Restore and Re-Jailbreak 5.1.1

    Hey

    I am trying to do a fresh restore on my iPhone4 to 5.1.1 (which i am currently on) and then to re-jailbreak it. I have following the instructions in the OP but each time i restore i get the following error pop up in iTunes:

    The iPhone "iPhone" could not be restored. This device isn't eligible for the requested build.

    Any ideas why this is? My SHSH blobs are saved from my phone and also from Cydia as you can see for the photo taken from TinyUmbrella



    I have stiched the ISPW and Blob together as you can see from my file name (of course replacing my ID Number with 0's)
    00000000000_iPhone3,1_5.1.1_9B206_Restore.ipsw

    Any ideas why this is happening?:smack:

    Thanks xD
    LiveProfile PIN: LPPFHDTK
  2. #2  
    Peligro911's Avatar
    iMore Genius

    Posts
    4,792 Posts
    Global Posts
    4,841 Global Posts
    iOS Version
    6 and 5

    Default Restore and Re-Jailbreak 5.1.1

    Is the ipsw you downloaded the correct one ?
  3. #3  
    3cit's Avatar
    iMore Elite

    Posts
    2,713 Posts
    iOS Version
    7.0.6

    Default Restore and Re-Jailbreak 5.1.1

    You need to use redsnow b15 (the latest) and put your phone into PWNED DFU state, then try shift restore in iTunes
  4. #4  
    iDonev's Avatar
    iMore Expert

    Posts
    874 Posts
    Global Posts
    877 Global Posts
    iOS Version
    6.1

    Default Re: Restore and Re-Jailbreak 5.1.1

    Both 3cit and Peligro911 make good points.

    First try 3cit's advice.
    If you're doing this already and it doesn't help, I recall that Apple issued a second version of 5.1.1 as noted on your screen shot - you have 5.1.1 and 5.1.1b. Make sure the blobs you stitch match with the firmware you download.
    If you have jailbreak woes, you can iMessage me at iDonev@me.com. I'll try to help (provided I have time to spare).
  5. Thread AuthorThread Author   #5  
    KBV1's Avatar
    iPhone Newbie

    Posts
    24 Posts
    Global Posts
    318 Global Posts
    iOS Version
    5.1.1

    Default Re: Restore and Re-Jailbreak 5.1.1

    Hi,

    I have tried the above but seem to still get the same error. I have the latest version for Mac, I have stitched the correct blob and firmware, but this error keeps occurring :/. hmm
    Last edited by KBV1; 11-19-2012 at 03:55 PM.
    LiveProfile PIN: LPPFHDTK
  6. #6  
    3cit's Avatar
    iMore Elite

    Posts
    2,713 Posts
    iOS Version
    7.0.6

    Default Re: Restore and Re-Jailbreak 5.1.1

    well, since you have a 4, i say you should restore as new using itunes, which will put you on 6.0.1 then get redsnow 15b and do the downgrade option to get back to a fresh 5.1.1
    i spent 8 hours one day trying to "restore" to 5.1.1 using redsnow and itunes and i could not make it happen.
    finally i updated to 6.0.1 then i tried downgrading using redsnow.
    do you have a gsm? or a cdma? i was doing this on a cdma phone
    the only thing i can figure is that maybe hosts are incorrect....
    do you get the same error each time??
    what visual cues do you get?
    like does your phone start to restore? sow the progress bar and suddenyl just fails? or does it not even get to that point and itunes gives you an error message?

    are you only trying to restore through redsnow? or are you trying to restore by building a properly stitched file, putting your phone into pwned dfu and then restoring in itunes using the shift+restore option
    Last edited by 3cit; 11-20-2012 at 04:24 AM.
  7. Thread AuthorThread Author   #7  
    KBV1's Avatar
    iPhone Newbie

    Posts
    24 Posts
    Global Posts
    318 Global Posts
    iOS Version
    5.1.1

    Default Re: Restore and Re-Jailbreak 5.1.1

    Quote Originally Posted by 3cit View Post
    well, since you have a 4, i say you should restore as new using itunes, which will put you on 6.0.1 then get redsnow 15b and do the downgrade option to get back to a fresh 5.1.1
    i spent 8 hours one day trying to "restore" to 5.1.1 using redsnow and itunes and i could not make it happen.
    finally i updated to 6.0.1 then i tried downgrading using redsnow.
    do you have a gsm? or a cdma? i was doing this on a cdma phone
    the only thing i can figure is that maybe hosts are incorrect....
    do you get the same error each time??
    what visual cues do you get?
    like does your phone start to restore? sow the progress bar and suddenyl just fails? or does it not even get to that point and itunes gives you an error message?

    are you only trying to restore through redsnow? or are you trying to restore by building a properly stitched file, putting your phone into pwned dfu and then restoring in itunes using the shift+restore option

    Hey!!
    First of its a GSM model.

    The point i get to when it errors is after the extracting in itunes, when the bar reaches full ready in to install, thats when i get the error message posted above every time

    I have tried to restore to 5.1.1 and also 5.1.1b both with each of the correct blobs, and using that custom firmware created after stitching. I enter my phone into pwdDFU mode via redsn0w with no hitch or errors.

    Thing is is i update to 6.0.1 and i cant downgrade I'm stuck on that crap then LOL!! Why can it never be simple

    Is there anything else i can try or im actually missing :/

    Thanks
    LiveProfile PIN: LPPFHDTK
  8. #8  
    3cit's Avatar
    iMore Elite

    Posts
    2,713 Posts
    iOS Version
    7.0.6

    Default Restore and Re-Jailbreak 5.1.1

    Manually edit your hosts to
    Point to cydia
  9. #9  
    1982ollie's Avatar
    iMore Pro

    Posts
    704 Posts
    iOS Version
    5.1.1

    Default Restore and Re-Jailbreak 5.1.1

    I can see this has already been point out.

    Don't forget guys there is a 206 and a 208 build for the iPhone 4 5.1.1. If you are trying to restore to the 206 build, you may have problems. Make sure when you download the firmware, that you are selecting the 208 build. As from you first post it doesn't look like you are, so you may be stitching the wrong blob to the wrong firmware.

    Stitch the 5.1.1r blob to the 208 build. You may of already tried. But I just had the same problem recently and it worked for me.
  10. #10  
    1982ollie's Avatar
    iMore Pro

    Posts
    704 Posts
    iOS Version
    5.1.1

    Default Restore and Re-Jailbreak 5.1.1

    Quote Originally Posted by KBV1 View Post
    Hey!!
    First of its a GSM model.

    The point i get to when it errors is after the extracting in itunes, when the bar reaches full ready in to install, thats when i get the error message posted above every time

    I have tried to restore to 5.1.1 and also 5.1.1b both with each of the correct blobs, and using that custom firmware created after stitching. I enter my phone into pwdDFU mode via redsn0w with no hitch or errors.

    Thing is is i update to 6.0.1 and i cant downgrade I'm stuck on that crap then LOL!! Why can it never be simple

    Is there anything else i can try or im actually missing :/

    Thanks
    If you have the blobs and it is defiantly an iPhone 4 gsm, you should be able to downgrade mate.

    Otherwise tethered 6.0.1 for you it is.

    I'm not budging from 5.1.1 till I know there is an un-tethered out there.

    Good luck with it.
  11. Thread AuthorThread Author   #11  
    KBV1's Avatar
    iPhone Newbie

    Posts
    24 Posts
    Global Posts
    318 Global Posts
    iOS Version
    5.1.1

    Default Re: Restore and Re-Jailbreak 5.1.1

    Quote Originally Posted by 3cit View Post
    Manually edit your hosts to
    Point to cydia
    How do i manually edit hosts to cydia?

    Thanks
    LiveProfile PIN: LPPFHDTK
  12. #12  
    3cit's Avatar
    iMore Elite

    Posts
    2,713 Posts
    iOS Version
    7.0.6

    Default Re: Restore and Re-Jailbreak 5.1.1

    Quote Originally Posted by KBV1 View Post
    How do i manually edit hosts to cydia?

    Thanks
    Mac OS X users can get to “/etc/” directory by going through “Go –> Go to Folder” from Finder.
    Open this “hosts” file in Notepad (for Windows) or TextEdit (for Mac OS X) and add this
    74.208.105.171 gs.apple.com
    Restore and Re-Jailbreak 5.1.1-21.png

    from redmond pie
  13. Thread AuthorThread Author   #13  
    KBV1's Avatar
    iPhone Newbie

    Posts
    24 Posts
    Global Posts
    318 Global Posts
    iOS Version
    5.1.1

    Default Re: Restore and Re-Jailbreak 5.1.1

    After editing my host file and trying again via stiching blob and FW I still get the error above. When trying to restore via iTunes and Tinyumbrella, I am presented with this;



    Hmm! Not really having much luck LOL!
    LiveProfile PIN: LPPFHDTK
  14. #14  
    rdiddy_25's Avatar
    iMore Genius

    Posts
    3,419 Posts
    Global Posts
    4,229 Global Posts
    iOS Version
    7.0.4/6.1

    Default Restore and Re-Jailbreak 5.1.1

    Quote Originally Posted by KBV1 View Post
    After editing my host file and trying again via stiching blob and FW I still get the error above. When trying to restore via iTunes and Tinyumbrella, I am presented with this;



    Hmm! Not really having much luck LOL!
    Since u have the iPhone 4, just upgrade to 6.0.1 and jailbreak. It will be tethered but jailbroken. Will save you a lot of time and more headaches.
  15. #15  
    3cit's Avatar
    iMore Elite

    Posts
    2,713 Posts
    iOS Version
    7.0.6

    Default Restore and Re-Jailbreak 5.1.1

    I also did not have any luck when re restoring...
    However, once I updated, I was able to downgrade on the first attempt.
    I say you try that route!
    I have a kickin thread about my experience somewhere!
    Thanked by:
    KBV1 (11-29-2012)
  16. Thread AuthorThread Author   #16  
    KBV1's Avatar
    iPhone Newbie

    Posts
    24 Posts
    Global Posts
    318 Global Posts
    iOS Version
    5.1.1

    Default Re: Restore and Re-Jailbreak 5.1.1

    I'm just trying to find that thread.. Have i missed it when looking lol
    LiveProfile PIN: LPPFHDTK
  17. #17  
    3cit's Avatar
    iMore Elite

    Posts
    2,713 Posts
    iOS Version
    7.0.6

    Default Re: Restore and Re-Jailbreak 5.1.1

    Quote Originally Posted by 3cit View Post
    As i restore my jailbroken phone as new for the 7th or 8th time now, i find myself wondering is this jailbreak even worth it?
    yesterday after updating winterboard and camera tweak, or something, the tweak that adds a bunch of (useless) options to the camera app, my phone got a little more than wonky!
    now i am a tweaker to the maxer... i have tweaks upon tweaks and i am fully aware that conflicts arise and im ok with it. generally i do opk for myself with an occasional mobile substrate crash now and again, but whatever, i dont have my iphone because "it just works" i have my iphone because "it works the way i want it"... ANYWAYS the phone shut down randomly, kater while talking to my wife, it just goes all black, nothing for about 30 seconds then i can hear her and she can hear me, then the spinner, the one you get as your phone is resrpinging... then poof respring. oh well. then it gets worse, in my car the bluetooth wont connect, the phone wont charge, home button is unresponsive (more than usual) bite gets crazy laggy etc.... my phone is jacked up. today i sent out a quick reply and my phone is unresponsive again, music is still playing but cant fast forward, pause, raise voulem, turn off screen... so im like ok restore.
    then i think am i going to go to ios and keep it clean? the thought last for about 1 millionth of a second.

    i NEED bite.

    i dont use safari, so i need browser changer, i dont like lots of folders and lots of springboard pages, so i need folder enhancer, i need 5 icon dock, i need ipsum, i need pandora downloader (for ths skips) i simply need these things. i need gridlock. i need bulletin
    i like lock info, i like winterboard, i like any attach, i like status tweak, and clean status (the two combined seem to be my biggest conflict)
    anyways im going to do a restore as new. and i figured since i was going to be sitting here anxiously anyways, i might as well write about it.
    this forum needs a little excitement anyways!
    so here goes.
    im on a new hard drive so first thing i do is download tiny umbrella 6.00.01 and redsnow 0.9.15b2.
    step 1 i am getting my blobs from my device via tiny umbrella, (i have requested some from cydia as well) i end up with (4.2.8 and 4.2.9 and 4.2.10, and 5.0 and 5.0.1 and 5.1.1 and 6.0 gm) which is every firmware that has come out since i had my iphone 4 (cdma, gsm would have 4.3.3 and 4.3.4, and 4.3.5....)
    now that i have my blobs saved locally, i am going to open up redsnow select extras, the select shsh blobs, then stitch then ipsw, then im going to select the ipsw i just downloaded, then i select local (because i have my blobs saved locally now) once i select the correct blob, in this case 5.1.1, redsnow kicks in and starts to stitch together my blobs for me, it takes just over 2 minutes. i take special note to where my custom blob was saved.
    now i go "back" one level in redsnow and i select even more, and then select restore.
    redsnow now gives me a warning saying my baseband wont be upgraded during this restore but that ill probabaly have to use recovery fix after restore is done, eh no biggie. so i select ok then i am told i am in normal mode and the i need to be in pwned dfu mode, and then redsnow walks me through the steps. (simple stuff, plug phone in, turn it off, hold power for three seconds, then both power and home for ten seconds, then just home for an additional 15+ seconds) turns out that ive never had my device connected to my computer while in dfu mode so i have to install drivers for redsnow to continue. this causes redsnow to shut down. ok well well try again. currently now my phone is in dfu mode and i am restarting redsnow (as administrator of course) so extras, even more, restore, select custom stitched firmware just created, because my phone is already in dfu mode it instantly exploits with limerain and reboots my phone. i get an exploit failed messsage... so i quit and see what happens when my phone reboots...
    so my phone rebooted into its previous state. ill just try again. phone powered down... redsnow started, (i turn off tiny umbrella to because that has been running all this time...) ok so that appeared to be the issue, i put my phone into pwned dfu and even though i already made a stitched blob, redsnow is again asking me for blobs, which i have saved. so after i select the proper blob again redsnow does some work, returns an error saying that it found none of the expected files. so i then am able to select an ipsw again, and i select the clean stock ipsw, then i select the proper blobs, this time redsnow gets a lot further along but then i get an error that says found device in dfu mode instead of recovery mode... now im a little frustrated as i was told to put it into dfu mode BY REDSNOW!
    ok so this time i just turn my phone off and i select enter pwned dfu mode.(for restore) and i get a message from redsnow saying that my phone is now ready for a custom recovery using itunes. so im going to start itunes now, then im going to start tiny umbrella and run the server, then im going to right click and restore in itunes and use my custom firmware.
    itunes started, get the itunes detect phone.... so now i start tinmy umbrella, start server, go back to itunes right click resore, select my custom stitched firmware of course when i opened tiny umbrealla itunes shut itself down. so i start itunes again, select restore, itunes prepares my phone and after 1 minute i get error 1600 cannot restore. phone is still in pwned dfu, black screen, tell tiny umbrella to kick it out, it doesnt.
    so i start redsnow again, and i select extras, even more restore, then i put my phone into pwned dfu simply by turning it off, then entering dfu at the appropriate time. This time i select a clean ipsw again, then i get message again about not updating baseband, then i select the blobs, and this time redsnow does a ton of work, uploads ram disk and reboots phone into recovery mode, which then forces anotherr driver install. i think that may be where the issue was last time. currently i am restoring system image, and my phone has the apple logo and the progress bar, its goign very slowly i might add....
    looking back at thsi there is A TON of little red lines in my post, but im not sure im going to proof read the entire post, also i notice that at some point i hopped into the middle of this post as i have text below whoch belongs above... im going to fix that now NOBODY IS GOING TO READ ALL OF THIS
    seriously this is taken a crap ton amount of time, i actually think that the process has gone awry and frozen up task manager says things are still running, a little patience is needed i guess ok so now im POSITIVE that the process has stalled. im a little concerned, my phone is in what appears to be a vulnerable state right now... i am going to use task manager to force redsnow to quit
    ok so phone restarts has familiar "connect to itunes" logo showing, nothing happens when i plug my phone in however. the computer doesnt even recognize that its there
    Quote Originally Posted by 3cit View Post
    so yesterday i posted a book in the apps hacks and themes section by accident, and i currently cannot open it. some kind of "redirect loop"... ANYWAYS
    long story short
    i could not in any way shape or form get it to restore as new on 5.1.1 from 5.1.1
    if i tried the redsnow method the phone would hang during the "formatting drive" part. if i put my phone into pwned dfu and tried to restore throgh itunes i got error 1600, if i turned off tiny umbrella i got error 3994.
    the point my post stopped at was with my halting the process while my phone was being "formatted" by redsnow. and the phone wasnt being recognized by my computer, again turns out to be a driver issue... my phone was in recovery mode and i didnt have the proper driver installed (agian, brand new hard drive) anyways after i rebooted computer the driver installed
    i then told apple to just restore and update
    so i was on 6.0 for about 5 minutes, because then i downloaded redsnow 14b and rebuilt my custom firmware, and put it into pwned dfu, i went into my host files and manually entered cydias host. (im wondering if tiny umbrella is no longer good for host services) and i was able to restore my iphone 4 to 5.1.1 stock (of course i got the -1 error in itunes, then had to use redsnow, again out it into pwned dfu, watch it upload the ram disk, etc... to kick it out of recovery mode)
    yes that was the short story
    i lost 4.5 hours yesterday on this crap!!!!
    i dont know what the issue was. perhaps it was because iw as too lazy to manually enter my hosts, perhaps it CANT BE DONE on a 4. who knows
    but either way, im on 5.1.1 jailbroken still.
    and if i need to restore as new, ill just go to 6.0, then downgrade.
    sherlock likes this.

Similar Threads

  1. My jailbroken iphone is lagging, thinking about restoring and re-jailbreaking...
    By rosenstar in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 20
    Last Post: 10-10-2011, 10:49 PM
  2. Can I restore and re jailbreak.com my VZ iPhone?
    By Greg G in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 7
    Last Post: 07-16-2011, 02:54 AM
  3. Restore and re-jailbreak. PLEASE help!
    By Matt1650 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 7
    Last Post: 12-02-2009, 02:21 PM
  4. Restore and re-jailbreak. PLEASE help!
    By Matt1650 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 2
    Last Post: 11-28-2009, 09:01 AM
  5. Restoring iPhone, Updating Firmware and Re-Jailbreaking - Confused.
    By Bobo in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 5
    Last Post: 10-24-2009, 12:16 PM

Posting Permissions