Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
  1. Thread AuthorThread Author   #1  
    rhinoriega's Avatar
    iPhone Nanite

    Posts
    5 Posts

    Default error 1015

    while downgrading from iOS 6.0.1 to 4.1.0 (with saved shsh blobs), I get the error 1015 or sometimes 1014. I've found little to no information about this error online, the few fixes that people propose havn't help me at all, I thank you all in advance if you have some information. And I would be most grateful if I could be answered ASAP. Thanks again.
  2. #2  
    JustMe'D's Avatar

    Posts
    19,266 Posts
    Global Posts
    19,495 Global Posts
    iOS Version
    7.0.4

    Default error 1015

    Thanked by:
    rhinoriega (11-10-2012)
  3. Thread AuthorThread Author   #3  
    rhinoriega's Avatar
    iPhone Nanite

    Posts
    5 Posts

    Default Re: error 1015

    ummm.... that didn't really help, but thanks anyway. More help is welcomed. Again, thanks in advance
  4. #4  
    JustMe'D's Avatar

    Posts
    19,266 Posts
    Global Posts
    19,495 Global Posts
    iOS Version
    7.0.4

    Default error 1015

    Have you tried ?
    Thanked by:
    rhinoriega (11-10-2012)
  5. Thread AuthorThread Author   #5  
    rhinoriega's Avatar
    iPhone Nanite

    Posts
    5 Posts

    Default Re: error 1015

    thanks for replaying again so fast, that was indeed helpful, however I've read that the libusb or something like that is not recommended to use at all, since it is quite outdated. Still trying to search for solutions. I've found quite a few, but I'm almost sure I'm misunderstanding the order of doing things, maybe you can help me. The guides I've found typically start when I'm in the loop, however, the error 1015 doesn't leads me to any loop, this is what happens:
    1. put my iphone in DFU
    2. start TU TSS server
    3. open itunes, shift click restore, select the iOS to which I have the shsh blobs (4.1.0)
    4. get error 1015 just before the loading bar below the apple logo on iphone screen finishes loading.
    (this is where I suppose most guides start, also where things start to not match)
    again, most guides talk about the device being in a 'loop' and not being able to get out of recovery mode, however, when the error goes off, I can slide to do an emergency call, and tap the unlock bottom to activate the SIM card [EDIT] which obviously doesn't activate (QUESTION!: at this point is this is the normal thing to happen? if it is, shouldn't at this moment I be in the 4.1.0 iOS I restored to using the shsh blobs?).

    I tried to use iReb but that didn't work, at least not the way I did it, which was DFU -> press the 'set auto-boot true (fixes 1015 errors / recovery loops) and THEN TU -> then itunes, but still got the error so I guess either I'm really unlucky or I did something wrong.

    Anway sorry for being so stubborn, and thanks a lot for trying to help me, hope you or someone else could respond this reply really soon
  6. #6  
    JustMe'D's Avatar

    Posts
    19,266 Posts
    Global Posts
    19,495 Global Posts
    iOS Version
    7.0.4

    Default error 1015

    You're very welcome. At this point, I'm hoping some of the people with jailbroken devices will chime in and provide some valuable information. I do not and have never had a jailbroken i-device so all I can do is what I've tried to do already and that is find information that may be of use to you. In the meantime, take care and have a great night...
    Thanked by:
    rhinoriega (11-10-2012)
  7. Thread AuthorThread Author   #7  
    rhinoriega's Avatar
    iPhone Nanite

    Posts
    5 Posts

    Default Re: error 1015

    I see now, well thank you very much indeed, have a good night as well

    [EDIT]

    btw to other people seeing this, after I get the error, I'm in this screen where I can slide to do an emergency call, and a message pops up asking me to write down the ping of my SIM card in order to unlock it, but when I put it in, it doesn't say anything, not even that the device doesn't support the SIM card or something like that. I just put the number in, tap OK and then nothing, the screen stays there. Is that the so called recovery mode?

    Another time, thanks in advance to anyone that reads and replies to this thread
  8. #8  
    Peligro911's Avatar
    iMore Genius

    Posts
    4,765 Posts
    Global Posts
    4,814 Global Posts
    iOS Version
    6 and 5

    Default error 1015

    Quote Originally Posted by rhinoriega View Post
    thanks for replaying again so fast, that was indeed helpful, however I've read that the libusb or something like that is not recommended to use at all, since it is quite outdated. Still trying to search for solutions. I've found quite a few, but I'm almost sure I'm misunderstanding the order of doing things, maybe you can help me. The guides I've found typically start when I'm in the loop, however, the error 1015 doesn't leads me to any loop, this is what happens:
    1. put my iphone in DFU
    2. start TU TSS server
    3. open itunes, shift click restore, select the iOS to which I have the shsh blobs (4.1.0)
    4. get error 1015 just before the loading bar below the apple logo on iphone screen finishes loading.
    (this is where I suppose most guides start, also where things start to not match)
    again, most guides talk about the device being in a 'loop' and not being able to get out of recovery mode, however, when the error goes off, I can slide to do an emergency call, and tap the unlock bottom to activate the SIM card [EDIT] which obviously doesn't activate (QUESTION!: at this point is this is the normal thing to happen? if it is, shouldn't at this moment I be in the 4.1.0 iOS I restored to using the shsh blobs?).

    I tried to use iReb but that didn't work, at least not the way I did it, which was DFU -> press the 'set auto-boot true (fixes 1015 errors / recovery loops) and THEN TU -> then itunes, but still got the error so I guess either I'm really unlucky or I did something wrong.

    Anway sorry for being so stubborn, and thanks a lot for trying to help me, hope you or someone else could respond this reply really soon
    Can you explain you said you have the blobs but did you stitch them into the ipsw file you are restoring ?


    Beamed from my iPad 2 routed and bouncing across the globe on multiple servers and brought to you using Tapatalk !
  9. #9  
    iDonev's Avatar
    iMore Expert

    Posts
    874 Posts
    Global Posts
    877 Global Posts
    iOS Version
    6.1

    Default Re: error 1015

    The way I see it, you didn't enter pwned DFU mode prior to restoring.

    Simply do what you did the very first time (before writing the post) with one extra step: before you do the Shift+Restore, go to redsn0w, Extras and choose pwned DFU, follow the instructions and then restore.

    If that didn't do the trick, I suggest you try a different USB port on the PC or a different PC altogether

    Also I was a little perplexed when you wrote about the emergency phone dial...
    Here are the four states an iPhone can be in:
    Normal - no explanation required
    DFU - black screen with nothing on it (except the phone's backlight)
    Recovery - an iTunes logo with a 30 pin connector
    Unactivated - the one you were describing with the emergency call slider

    If you are using the official carrier for the phone, inserting the SIM card should fix this screen and you should find yourself back on iOS 4.
    Last edited by iDonev; 11-11-2012 at 02:10 AM.
    If you have jailbreak woes, you can iMessage me at iDonev@me.com. I'll try to help (provided I have time to spare).
  10. Thread AuthorThread Author   #10  
    rhinoriega's Avatar
    iPhone Nanite

    Posts
    5 Posts

    Default Re: error 1015

    about the blobs, I did try to stitch them, but redsn0w claimed that the blobs weren't valid, maybe because I saved them with ish. Luckily, I was able to overcome this problem, or maybe a word more fit would be to go around.

    seeing iDonev reply (thanks for replying to fast btw) I realized that it was a mere thing of the phone not being unlocked (it had become locked previously), I tried a few times to jailbreak the phone but for some reason it failed, so that led me to think that that wasn't the right path. But to anyone with the same problem, just keep trying. Eventually the jailbreak went through, with that I upgraded the baseband to the iPad one, then downgraded it (both through redsn0ws's latest version) and now I'm in the process of upgrading to iOS 6, this time making sure the baseband doesn't updates.

    Thanks to everyone that replied here, I guess you close this thread or whatever.

Similar Threads

  1. iphone 3g 8gb An unknown error occurred (1015)
    By msa969 in forum iPhone 3GS Forum
    Replies: 12
    Last Post: 03-26-2014, 08:37 AM
  2. 3GS error 1015 restore loop. Help pls?
    By meerkat in forum iPhone 3GS Forum
    Replies: 10
    Last Post: 08-21-2011, 07:06 AM
  3. 3GS error 1015! Help loosing my mind!
    By Reptar in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 3
    Last Post: 07-21-2011, 04:49 AM
  4. error 1015, best way to fix?
    By duhockey in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 5
    Last Post: 04-28-2011, 12:03 AM
  5. Error code 1015 on 3.1.2 restore
    By Nht in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 8
    Last Post: 05-20-2010, 01:00 PM

Posting Permissions