Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread AuthorThread Author   #1  
    nicoleann978's Avatar
    iPhone Nanite

    1 Posts
    Global Posts
    5 Global Posts

    Default ios5 jailbreak for iphone 4

    I've been trying to jailbreak my iPhone 4 with redsnow. I can get as far as when it's supposed to reboot and then it just doesn't load anything. My phone just turns back on. Can someone tell me what to do? Thank you.
  2. #2  
    Bittersweet BB's Avatar
    iPhone Newbie

    16 Posts
    Global Posts
    201 Global Posts


    Same exact problem here. It went through the whole process, then I got to the stage of having to do the tethered reboot. But it just seems it starts the whole process over. My phone turns back on and the new icon is there but it's just a white square. And if I click on it, it basically almost looks like it's about to launch, but then just goes right back to the home screen again.

    Not sure what to do. Can anyone help?
  3. #3  
    GsxRz's Avatar
    iPhone Nanite

    3 Posts

    Default Hope this helps

    Ok, I'm no expert on jailbreaking, but here's my suggestion...

    What version of redsn0w are you using? The latest out is 0.9.10b5 make sure you're using the most up to date version.

    Next I think it sounds like you're getting just a partial jailbreak and install of Cydia done, you need to try doing something else than probably just pulling in and going through maybe.

    Are you using a mac or pc? Either way I believe redsn0w has the same prompts, (I use mac). Oh and first things first connect to iTunes and do a backup in case you run into any issues.

    What you should try doing is downloading the most recent version of redsn0w, and the most recent iOS for the phone 5.0.1 from Apple. Save the iOS file somewhere easy to find like your desktop or something.

    Open redsn0w, click on "EXTRAS" then click "SELECT IPSW" and point to the iOS file that I mentioned putting somewhere easy to find.

    Now hit "BACK" then jailbreak and "Install Cydia" should be checked.

    It's really easy, and there's tons of walkthroughs that are really good here or if you google it, and lot's of people on the forum will help you.

    Good luck!

    Oh and I just thought of this, when you do your backup on iTunes, try doing a restore as well and starting fresh, it probably wouldn't hurt.
    Last edited by GsxRz; 02-13-2012 at 12:34 PM. Reason: thought of something else that might help...
  4. #4  
    Bugeyeblue's Avatar
    iPhone Intermediate

    163 Posts
    Global Posts
    320 Global Posts


    I'm having this problem that the original poster had too. I'm on a verizon iphone 4 using the latest version of redsnow and of ios. Any other suggestions?

Posting Permissions