Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    jryoung25's Avatar
    iPhone Nanite

    3 Posts
    Global Posts
    8 Global Posts

    Default iPhone 4s iOS 5.0.1 - lost network

    I successfully jail broke my iPhone and then all of the sudden about 15 hours later I am no longer able to make phone calls and I lost my network provider? Anyone else know how to fix this? Mac user used Absinthe
  2. #2  
    RemmyZero's Avatar
    iMore Beginner

    68 Posts
    Global Posts
    210 Global Posts


    this happened to me on my iP4 as well, i don't know if it's jailbreak related or not. if you're sure your settings for mobile network and connectivity are ok and you think it's a JB issue then just back up your phone and restore in iTunes to 5.0.1. i had to get a replacement iPhone in the end.
  3. #3  
    Vanquish1's Avatar
    iMore Newbie

    12 Posts
    Global Posts
    58 Global Posts


    i too had this problem and the cause of the problem was toggling off 3G with SBSetting and then toggling it back on. It would never come back on eventhough the sign would light up like it was on. the fix for me was to:
    (1) Go in to Network Settings (2) Disable data roaming and voice roaming (3) Re-enable whatever settings you prefer
    then bam I was fixed and I disabled 3G as an option in my SBSetting so I could never do it again LOL. was without my connection for around 8 hours. I was just about to restore back to pure before I found that little buddy. Let me know if it helps.

Posting Permissions