Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread AuthorThread Author   #1  
    itslikecrackyo's Avatar
    iPhone Newbie

    10 Posts

    Default phone froze

    I'm posting this thread here because my phone is jailbroken, so this is the only place I could think of. Today after I had used Waze, and killed the app through the multitask thing, the phone just froze, except the screen is not black. It's stuck in multitask mode with the 4 icons in the muiltitask tray shaking. I tried holding the power button but it didn't work. I tried to sync my phone, but still nothing. Is my phone bricked? How do I fix this? I was thinking about just letting the phone run its course and let the battery die but I really am gonna need my phone in a few hours so I don't think I can wait that long. Help please.
  2. #2  
    BLiNK's Avatar
    iMore Genius

    8,216 Posts
    Global Posts
    8,563 Global Posts


    have you tried rebooting the device?

Posting Permissions