Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
  1. Thread AuthorThread Author   #1  
    corkyefes's Avatar
    iPhone Nanite

    Posts
    8 Posts

    Default No Service after iOS 5.01 Update

    Hi Guys,

    Looking for some help.

    I bought a second hand iPhone 3GS from my mate (which i believe was jailbroken or has been in the past).

    I connected the phone to itunes one day and it updated to iOS 5.0 and i suddenly came across the "no service" problem.

    I followed a tutorial on how to sort this, which worked (after alot of time spent on it) and the phone was working fine.

    However, suddenly the phone started say 'No Sim' and crashed.

    I had to plug the phone into itunes and restore the phone, however it restored and updated it to iOS 5.01
    Now i am getting the "No Service" problem again and i have followed the same tutorial to sort it, however it doesnt work. I tried re jailbreaking the phone using the 5.0 ipsw.
    (Im not sure if this would work anyway with it being updated to 5.01 however the latest version of redsnow does not support the iOS 5.01 ipsw)

    Has anybody come across this problem and how have they sorted it?
    I can restore the phone back to factory settings which will put the phone onto iOS 5.01.

    Can the phone be restored/downgraded back from 5.01 to say 4.33? (I understand its not possible to restore to 5.0)
    If so, can anybody point me in the direction of some step by step instructions?

    Some help would be greatly appreciated....im stuck without my phone.

    Thanks in advance.

    Corkyefes
  2. #2  
    iDonev's Avatar
    iMore Expert

    Posts
    874 Posts
    Global Posts
    877 Global Posts
    iOS Version
    6.1

    Default

    The reason you see the "No Service" message is because ultrasn0w hasn't been updated to support 5.0.1 ( I'm assuming you're an unlocker)

    As to downgrading to 4.3.3: check Cydia to see if you have saved the SHSH blobs. If so, there shouldn't be any problems downgrading.

    Word of caution: before doing anything, check to see if you haven't updated your baseband to a version that's unsupported by ultrasn0w.
  3. Thread AuthorThread Author   #3  
    corkyefes's Avatar
    iPhone Nanite

    Posts
    8 Posts

    Default

    Hi iDonev,

    Thanks for the reply.

    Right ok, so if ultrasn0w isn't supporting 5.01, i cannot unlock my phone? There is no other way?

    With regards to SHSH blobs, the phone is currently just at factory settings stage with iOS 5.01 installed. So i very much doubt SHSH blobs have saved. Well i definatly havent saved them or i if i have, i havent known about it. So without them saved i cannot downgrade? How can i check.

    When i tried to downgrade before, i got error 3194.

    What should my baseband be to fix the "no service" error.

    Thanks for the help.
  4. #4  
    Ipheuria's Avatar

    Posts
    6,786 Posts
    Global Posts
    6,819 Global Posts
    iOS Version
    iOS 6

    Default

    Jailbreak and Unlock are two different things but you do need to Jailbreak the phone in order to unlock. So even if your baseband is ok for unlocking without a way to get from 5.0.1. to 5.0 or lower you wouldn't be albe to do anything anywa. Now I thought I saw a new version of redsn0w which could JB 5.0.1? anyway the person is right first you need to check your baseband. You go into Settings, General, About and look for Modem Firmware and look at the version. Then go here it lists the basebands that are unlockable. You also have the option of putting the iPad baseband on the phone but do a search on here to see the caveats to doing that method. Now if you want to JB the phone go here it has the listen methods and tutorials on how to do them. If you want to JB the 5.0.1 then go here just make sure that you read it through and if there is a method to do it without upgrading the baseband, assuming yours is still unlockable then do it. If not and you can't downgrade you're stuck waiting it out until they release it.

    Update
    Checked it and it has all your questions answered so follow the link

    For Unlockers Only:

    you’ll need to create a custom .IPSW, which will preserve your baseband.
    To achieve this, open Redsn0w, select "Extras", then "Custom IPSW", then point Redsn0w to your iOS 5.0.1 file, and let Redsn0w do the rest.
    Finally, enter pwned DFU mode (Extras > Pwned DFU) and restore to your custom firmware via iTunes.

    You may also like to check out:
    How to downgrade iOS 5.0.1 To 4.3.3, 4.3.5 On iPhone 4, 3GS, iPad 2/1, iPod touch [How To Tutorial]
    Last edited by Ipheuria; 11-14-2011 at 08:51 AM.
    can't upgrade via iTunes check this thread http://forum.tipb.com/jailbreak-unlo...ml#post1717460
    ~32GB Space Grey iPhone 5s(Audi)~32GB Space Grey rMini ~ 15" i7 SSD 16GB rMBP(Omega) on Mavericks~
    iPheuria aka The Jailbr3ak kid (soon to be retired)
  5. Thread AuthorThread Author   #5  
    corkyefes's Avatar
    iPhone Nanite

    Posts
    8 Posts

    Default

    Hi Ipheuria,

    Thanks for the reply.

    I can jailbreak the phone fine using the latest redsnow and the iOS 5.0 ipsw. However i still get no service.
    (Im not sure what the baseband is when i jailbreak it, however i would guess as i flash the baseband through redsnow, surely it would make it 6.15.00?)

    However, I forgot that i had to unlock the phone (which is probably the reason for my "no service" error?) however i see that ultrasn0w is unable to unlock a phone that is on iOS 5.01....therefore is there another way to unlock?

    Im going to look at restoring / downgrade the phone to an earlier iOS after i have jailbroke the phone on the above method.

    I will check the phone then to see if it has any SHSH blobs saved (im guessing it won't have as i restored the phone back to factory settings and it updated to 5.01)

    So basically as i have looked into it, untill ultrasn0w support 5.01 (which may be ages away) or i have some SHSH blobs saved (which will be a miracle)...i am without a phone?

    If you or anyone else has any suggestions (i would need some instructions) on how i can get round this, i would greatly appreciate it....I am lost without my phone.

    This is sometimes why i hate apple!

    Thanks for your help
  6. #6  
    xrul's Avatar
    iPhone Nanite

    Posts
    2 Posts

    Default

    The only way is to unlock is downgrading the phone from iOS 5.01 to 4.1.
    I had the same problem. I used redsn0w latest version to enter pwned DFU mode. Then connected to itunes, updated to latest version. itunes then recognized my phone as being in recovery mode and showed a restore button. I hit Shift + Restore then chose 4.1 firmware i previously downloaded. It took a minute to restore the iphone. Afterwards I used redsn0w to reinstall ipad baseband, clicked on extras, select ipsw, chose 4.1 file, back, jailbreak, ticked install ipad baseband and next>. When finished i did the previous procedure but i ticked install cydia instead. then I just installed ultrasn0w, rebooted and it took just a few seconds to get signal!
  7. #7  
    aegraham's Avatar
    iPhone Nanite

    Posts
    6 Posts
    Global Posts
    17 Global Posts

    Default

    Not sure if this is much help, but I was in almost the same situation. Went out of town this last weekend with my 5.0 3GS (jailbroken and unlocked w/ GoPhone SIM) working perfectly. Not sure what happened but about halfway through the weekend my phone lost signal and got stuck in an "Searching...Service...No Service...Searching..." loop. Tried rebooting, hard reset, airplane mode...everything I could think to do without access to a computer.

    Got home yesterday and in a fit of rage upgraded to 5.0.1 via Snowbreeze custom IPSW (after spending 2 hours with Redsn0w). Installed UltraSn0w (1.2.4) and SAMPrefs and Custom APN but was still stuck in the same loop. After much Googling, ended up turning off my 3G. That seems to have fixed the problem for now. Kinda sucks that I don't have 3G, but at least EDGE seems to work fine and voice works too.

    Hope that helps somebody.
    Last edited by aegraham; 11-22-2011 at 09:27 AM.
  8. #8  
    aegraham's Avatar
    iPhone Nanite

    Posts
    6 Posts
    Global Posts
    17 Global Posts

    Default

    Quote Originally Posted by xrul View Post
    The only way is to unlock is downgrading the phone from iOS 5.01 to 4.1.
    I had the same problem. I used redsn0w latest version to enter pwned DFU mode. Then connected to itunes, updated to latest version. itunes then recognized my phone as being in recovery mode and showed a restore button. I hit Shift + Restore then chose 4.1 firmware i previously downloaded. It took a minute to restore the iphone. Afterwards I used redsn0w to reinstall ipad baseband, clicked on extras, select ipsw, chose 4.1 file, back, jailbreak, ticked install ipad baseband and next>. When finished i did the previous procedure but i ticked install cydia instead. then I just installed ultrasn0w, rebooted and it took just a few seconds to get signal!
    When you downgraded to 4.1, did it fix the GPS problem with the iPad baseband?
  9. #9  
    xrul's Avatar
    iPhone Nanite

    Posts
    2 Posts

    Default

    Quote Originally Posted by aegraham View Post
    When you downgraded to 4.1, did it fix the GPS problem with the iPad baseband?
    No, it did not fix the issue with the GPS.
  10. #10  
    edden's Avatar
    iPhone Nanite

    Posts
    1 Posts

    Default Fix GPS

    after restore back to 4.1 update or re flash your BB again will fix the "no sim" problem

Posting Permissions

B