Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread AuthorThread Author   #1  
    conan1071's Avatar
    iMore Newbie

    21 Posts
    Global Posts
    571 Global Posts

    Default iphone 3g with 4.2.1 jailbreak stuck!!??!!??1

    I used redsnow to jailbreak iphone 3g with 4.2.1 and everything went fine until the end when the phone tried to reboot its stuck on the apple logo. I tried to DFU again and doesnt work. iTunes on my computer isnt for this iphone. What can I do???
  2. #2  
    Eileen89's Avatar
    iMore Genius

    5,873 Posts
    Global Posts
    6,460 Global Posts


    This happened to me the first time I used jailbreak.com on my old 3GS. Although this video displays the iPhone 4, the steps will also work on your iPhone 3G as well. You will need to turn your iPhone off before getting it into DFU mode (the steps are in link).

    I hope this works for you.

Posting Permissions