Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread AuthorThread Author   #1  
    GadgetMomma's Avatar
    iMore Newbie

    42 Posts
    Global Posts
    241 Global Posts

    Default JB'ing messed up my iPhone4 - it won't even turn on! PLEASE help

    I have jailbroken every iphone I've had, and I previously had my 4 jailbroken. I restored it back a couple weeks ago, because I wasn't thrilled with the jailbreak on 4.3.1. I decided to jb again on 4.3.3, and I did everything like I was supposed to. The only problem is that when I went to enter my phone into DFU mode, it kept popping up saying it couldn't detect a phone. So I just checked my cord to make sure it was in the computer correctly (which it should have been, it was plugged up charging earlier), and I tried it again. It still wouldn't work - but not only that, now my phone won't turn on AT ALL. And when I open itunes, it recognizes that there is a phone plugged up, but it says

    "iTunes could not connect to this iPhone because an unknown error occurred.

    WHAT does this mean? And WHAT did I do to my phone? Did I brick it? If I did, how in the world do I get it back since the computer won't even recognize my phone? Please please please help me - I'm like most people now and only use my cell phone - no landline, and I stay at home with my kids, so I desperately need a phone! THanks for any help.
  2. #2  
    Ipheuria's Avatar
    iMore Genius

    7,265 Posts
    Global Posts
    7,332 Global Posts


    Unplug your phone and hold the Home & Power until the screen goes blank then hold power until you see the Apple. What are you using to JB? Also are you using an Apple cable? I've had problems in the past everytime getting into DFU mode with a 3rd party USB cable. Did you try reloading the firmware at all?
  3. #3  
    ckalli's Avatar
    iMore Intermediate

    177 Posts
    Global Posts
    188 Global Posts


    u need to restore it and then jailbreak again.. doubt u can use the same firmware.
  4. #4  
    joyfulgrrrl74's Avatar
    iPhone Nanite

    1 Posts


    This happened to me 2 nights ago. I had to uninstall iTunes then reinstall it. And use a different USB port. It worked like a charm. But it took me 2 hours of research and still not finding an answer. Lol so I just tried it and it worked for me.

Posting Permissions