Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    capo's Avatar
    iPhone Nanite

    1 Posts

    Default Jailbroken/unlocked but no service

    I've just changed providers and want to use my 3gs with the new provider. I jailbroke the phone (4.3.2) with redsn0w 0.9.6, then ran cydia to get ultrasn0w. I've installed the other sim but the phone keeps saying "searching" followed by "no service". I've tried using other activated sims, with the same results. Can anyone tell me what I've missed here? I'm not very savvy with the stuff, and basically just followed instructions from online so it's quite possible I missed a crucial step here somewhere. Thanks!
  2. #2  
    Ipheuria's Avatar
    iMore Genius

    7,265 Posts
    Global Posts
    7,332 Global Posts


    First you need to check your baseband Settings -> General -> About and look for Modem Firmware version or something similar. Go to http://www.iclarified.com/entry/index.php?enid=4253 and it will show you all the versions of the baseband that are unlockable. If your phone was on 4.3.2 then I doubt it's on an unlockable baseband. You can install Ultrasn0w but that doesn't mean it's unlocked unless you have an unlockable baseband. If you don't then you need to look on the first page for a thread from someone asking how to JB/Unlock his 3Gs Massie and I have already discussed the alternative and it's cautions.

    Ofcourse the site opened once I posted this 04.26.08, 05.11.07, 05.12.01, 05.13.04, 06.15.00, or 01.59 those are the basebands, Modem firmware versions that are unlockable.
  3. #3  
    New2iPhone's Avatar
    iPhone Nanite

    1 Posts

    Unhappy iPhone was workin until....

    I have kind of have the same problem. I jailbroke and unlocked my iPhone last night. Orginally had BB 05.15.04 and upgraded to 06.15.00 with FW 4.2.1. Was working fine with T-mobile sim (made phone calls, used internet, and sent txt msgs. Then this morning I open Cydia and it says it has critical updates I need. So I download them. When I come back to the phone a whole lot has been downloaded but now it says "no service". I have no internet, can't make any calls, all received call are going str8 to vm....what went wrong and what do I need to do to fix this??? Currently at work and I don't have Admin rights on this comp and my iPhone says I have no internet connection.

    Any help is greatly appreciated.

Tags for this Thread

Posting Permissions