Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread AuthorThread Author   #1  
    mrwonka75's Avatar
    iPhone Beginner

    Posts
    54 Posts
    Global Posts
    137 Global Posts

    Default Having problems with my new iPhone 4

    I have just jailbroken my iPhone 4 with green poison. I love all the things I can do with it, but I'm having problems with my battery draining way too fast now. Also having a lot of problems with safari crashing all the time! I clear all my history, cookies, and cache daily and reboot. I'm not sure if I have put something on my phone that is causing all these problems. Should I just unjailbreak? If so how do I do it? I tried restore on iTunes and everything stayed the same! Or can I just erase all my jailbreak stuff, and start over? Any suggestions would be great! I did look for a specific thread, but was unable to find one so before someone yells at me, you can just point me in the right direction. Thanx in advance!
  2. #2  
    Alli's Avatar
    iMore Genius

    Posts
    10,934 Posts
    Global Posts
    13,726 Global Posts

    Default

    If you did a restore on iTunes, you're no longer jailbroken.

    Next time, look in the jailbreak forum, where this thread is now located.
  3. Thread AuthorThread Author   #3  
    mrwonka75's Avatar
    iPhone Beginner

    Posts
    54 Posts
    Global Posts
    137 Global Posts

    Default

    That's the thing. I still have all the features that being jailbroken has! Thanx. I'll look in the other forum.
  4. #4  
    big9erfan's Avatar
    iMore Elite

    Posts
    2,454 Posts
    Global Posts
    2,455 Global Posts

    Default

    Do a restore as new device. This will reset your device back to a new state but it will likely upgrade you to 4.3 which only supports a tethered jailbreak right now. You will want to see if cydia has your 4.2.1 shsh blobs before doing this.
  5. #5  
    phoon61's Avatar
    iMore Intermediate

    Posts
    115 Posts
    Global Posts
    116 Global Posts

    Default

    Same thing happened to me.
    I restored to a custom 4.2.1 firmware i downloaded and once finished it was in DFU mode it wouldn't come out.
    I had to jailbreak with greenpoison when it was in DFU mode and it worked perfect.


    It works way better now.
  6. Thread AuthorThread Author   #6  
    mrwonka75's Avatar
    iPhone Beginner

    Posts
    54 Posts
    Global Posts
    137 Global Posts

    Default

    I'm on 4.2.6. so I need to restore as a new device? Then try to reinstall the JB. I'm pretty sure I was in DFU mode when I did it the first time.

Posting Permissions