Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 1 of 1
  1. Thread AuthorThread Author   #1  
    ridingtime's Avatar
    iPhone Nanite

    1 Posts

    Default Problems after unlocking iPhone 4 4.0.1 1.59 bb

    I have an iPhone 4 with firmware 4.0.1 (never felt a need to update) and 1.59 baseband. I bought it with AT&T and now have been needing it to use the Orange network in Israel. I am pretty sure I jailbreaked it with jailbreakme.com. I recently unlocked the phone with ultrasn0w 1.2 using cydia and the whole process went smoothly.

    The problem though that I am having is that the unlock seems to not stay permanent, especially after I shut down the phone and turn it back on, or if I do a soft reset. Not only that, the WiFi is more fickle than it has ever been, many times just not working. Sometimes the phone won't be able to find the WiFi either unless I turn off all cellular data settings. Usually the WiFi stops working first, and then all together the unlock stops working and no cellular data works.

    I have been able to fix the problem by uninstalling ultrasn0w, restarting the phone, and then reinstalling it. But sometimes I need to do this process several times before I have things working, and then eventually after some time, everything breaks down again.

    It's a very frustrating experience and I would really really appreciate any help I can get with this. Thanks in advance!

Posting Permissions