Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    JGK#IM's Avatar
    iPhone Nanite

    2 Posts

    Default Never jailbroken/unlocked before, point me in the right direction!

    To clarify, I've never jailbroken successfully.

    I was handed down an iPhone 3G from my brother, who recently upgraded to an iPhone 4. I decided to follow a few jailbreak tutorials online, but I unsuccessful, and somehow my iPhone upgraded to iOS 4.1 during the process (iPhone was originally on iOS 3.1.3).

    Before I bore you with any other stories, I'll just leave you with the critical information:

    -iPhone 3G on iOS 4.1
    -My brother "reset" the iPhone, which may be the problem I'm dealing with. When I turn on the phone, it's awaiting activation.
    -I am a T-Mobile customer. I believe I'm trying to "unlock" this iPhone
    -I'm essentially working with this phone without it's original SIM, since the current SIM is being used with my brother's iPhone 4.
    -Using Windows Vista
    -Have been able to use the phone as an iPod, but little else

    Before I set out again and dig up a tutorial somewhere, I just want to make sure I won't botch this jailbreak job. I've hacked my PSP and Wii successfully, so I don't think I'm inept in doing this, just unfamiliar with the jailbreak process!

    Any input would be appreciated! Thanks.
  2. #2  
    myzhi's Avatar
    iPhone Intermediate

    366 Posts


    Upgrading to 4.1 firmware also upgrades the baseband to 5.14. Currently, that baseband can't be unlock to use with different carriers, like T-Mobile. If the 3G iPhone has 5.08 bootloader, there is hope.

    iH8sn0w.com | Jailbreak your iPod touches and iPhones
    Use F0recast (link ^^^) and see if you have 5.08 bootloader =>use Fuzzyband to downgrade to unlockable baseband.

    If you do, JB with Redsn0w which adds Cydia. In Cydia, install Fuzzyband to downgrade the baseband, and then, install Ultrasn0w to unlock so you can use it with T-mobile.

    If you don't, you will need to wait for possible 5.14 baseband unlock. As to when, nobody knows. Latest rumor is shortly after 4.2 firmware is released.
  3. Thread AuthorThread Author   #3  
    JGK#IM's Avatar
    iPhone Nanite

    2 Posts


    Thanks for that link myzhi, I ran f0recast and this is what i got -

    Baseband: 05.14.02
    Bootloader: 5.8
    Jailbreakable: Yes (always)
    Unlockable: No
    Tethered: No
    I think there is hope. Like you mentioned, f0recast prompted me with a message saying I can downgrade basebands since I have Bootloader 5.8.

    Do you have a tutorial for redsn0w? Like I mentioned, the phone is still awaiting activation so I don't know if that complicates anything.

    Thanks again myzhi!

Posting Permissions