Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread AuthorThread Author   #1  
    scoobydrew831's Avatar
    iPhone Newbie

    12 Posts

    Default Please help iPhone 4 unlock problem No Service/InvalidSIM + one bar w/o carrier name

    I have an unlocked iphone 4 running on T-mobile. I have gone through 3 iPhone 4s and all of them have had the problem I'm about to describe, so it must be a problem with something I'm doing.

    I activate my no contract phone thru iTunes with the blank ATT so that I can jailbreak. NOTE the "Waiting for Activation this may take some time" screen still appears and only dissapears once I unlock and get T-Mobile service. After restoring from backup, I jailbreak with jailbreakme. Next, I install ultrasn0w and insert my T-Mobile (cut with Microsim Cutter) sim. For the first 10-15 turnons of the device, the unlock is working just fine. After about 10-15 turnons, I will turn my iPhone on and instead of having T-Mobile signal, I either get "No Service", "Invalid SIM", or the most common one: one bar with no carrier name with which I cannot use any cellular function. I have researched this problem for hours and found people with the same problem but nobodys post has any responses. I AM DESPERATE ANY HELP WOULD BE GREAT AND A LIFE SAVER!!! BTW i have iPhone 4 16gb with 4.0.1.
    Last edited by scoobydrew831; 09-22-2010 at 05:46 AM.
  2. #2  
    myzhi's Avatar
    iPhone Intermediate

    366 Posts


    Heard tmobile has iPhone support team. Try contacting them. You can also try: Unlockit - APN Changer for your iPhone through safari on the phone to change he apn settings.

Posting Permissions