Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    scotiwis's Avatar
    iPhone Nanite

    1 Posts

    Default Ultrasn0w problem - Different SIM Detected

    Hi it seems this is quite common.
    I have a vodafone NZ sim card and a locked iphone 4 from UK.
    I got an activation card from China and I can now get past the emergency screen.
    I jailbroke with jailbreakme.com no problem
    Unlocked with ultrasn0w
    When I put the vodafone sim in it says Different SIM detected and I'm locked out the phone again.

    If I reinstall ultrasn0w and insert the sim at just the right time when it's rebooting I can get everything to work temporarily but then synching to itunes, turning phone off and on, or rebooting goes back to Different SIM Detected.

    I see loads of people with this issue, has anyone got a solution?
    Last edited by scotiwis; 08-05-2010 at 09:17 PM.
  2. #2  
    PinkBanana's Avatar
    iMore Intermediate

    182 Posts
    Global Posts
    183 Global Posts


    I had a similar problem with ultrasnow too. my iphone is locked to orange, i've never had it officially unlocked and previously used ultrasnow to use it with my vodafone sim. now i'm back on orange, i installed ultrasnow and yesterday noticed my signal had no bars. I had a signal as it didn't say no service. Just no bars. So i've uninstalled ultra and not had a problem since.
  3. #3  
    innocentmonda's Avatar
    iPhone Newbie

    12 Posts
    Global Posts
    13 Global Posts


    i think still we are suffering to jailbreak and unlock iphone 4.

Posting Permissions