Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    Spinnhead's Avatar
    iPhone Nanite

    1 Posts

    Default Help with jailbreaking 3GS and 3G

    Ive just jailbreaked my iphone with redsn0w and used ultrasn0w to unlock it, but i dont get any signal. It says "No service".

    What to do?


    Firmware: 4.0
    Baseband: 05.13.04
    Bootloader: 5.9
    Model: MB489

    Jailbreakable?: YES (Always)
    Unloackable?: NO
    Tethered?: NO

    I also got an iphone 3gs that i tried to use snowbreeze on, but it didnt work to jb it.


    Firmware: 4.0
    Baseband: 05.13.04
    Bootloader: 6.4
    Model: MC134

    Jailbreakable?: -Blank-
    Unlockable?: NO
    Tethered?: Maybe - Depends if Refurb..

  2. #2  
    hare619's Avatar
    iPhone Newbie

    21 Posts
    Global Posts
    23 Global Posts


    I also have a 3GS that's running 4.0. As of right now they cannot be unlocked or jailbroken yet. They will be able to soon is what I'm hearing but right now it's not able to.
  3. #3  
    big9erfan's Avatar
    iMore Elite

    2,454 Posts
    Global Posts
    2,455 Global Posts


    If you have a 3GS and it's already on 4.0 and it WASN'T jailbroken before 4.0, you can't do anything right now.

    If it was jailbroken before 4.0 AND you haven't upgraded to 4.0 yet and it's not tethered ( if it's an MC model you're likely tethered ), then it's possible using sn0wbreeze.

    On your 3G try doing a "Reset Network Settings" and see if that enables your service.

Posting Permissions