Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    longshadows's Avatar
    iPhone Beginner

    55 Posts
    Global Posts
    56 Global Posts

    Default Can't update some apps on version 3.1.2

    I'm iPhone 3Gs jailbroken and holding at version 3.1.2, but more and more I'm encountering App upgrades that "require a newer version of the OS." It seems that the older app version gets removed by iTunes and not replaced! This is manageable, so far, as these are not necessary Apps, but it's getting worse each week. Any thoughts?

  2. #2  
    Alli's Avatar
    iMore Genius

    10,934 Posts
    Global Posts
    13,726 Global Posts


    Happens that way with every major upgrade.
  3. #3  
    big9erfan's Avatar
    iMore Elite

    2,454 Posts
    Global Posts
    2,455 Global Posts


    You just have to be careful with letting iTunes update all your apps blindly.

Posting Permissions