Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
  1. Thread AuthorThread Author   #1  
    ElectricDoodie's Avatar
    iPhone Newbie

    Posts
    48 Posts

    Default 3GS 3.1 can't upgrade to 3.1.2

    I have a 3Gs iPhone that has 3.1 on it.

    I want to jailbreak it and I've found a guide that uses blackra1n, and it can jailbreak 3.1.2.

    This is the site:

    redmondpie..com/jailbreak-iphone-3.1.2-firmware-with-blackra1n-zni327/

    It tells me that I need to have 3.1.2, so they give you a link to download it. I went to the link, and downloaded it. When I try to install it, it tells me that it apple won't let me, because it tells me that the device is not eligible for the requested build.

    I don't want to update to 3.1.3, as I won't be able to jailbreak it. And I need 3.1.2 to do it. So, I have to upgrade from my 3.1 to 3.1.2, but Apple seems to only allow me to install 3.1.3.

    Is there a way to fix this? I'm guessing that it's not giving me the ability to install 3.1.2 on it when I shift+restore, because I never had 3.1.2 installed on it before. In other words, it can't restore my phone to something that was never on it in the first place.

    Am I just stuck, and should just install 3.1.3 on my non-jailbroken iPhone, and just wait for there to be a new tool out that can do it?

    OR

    Is it possible for me to upgrade to 3.1.3, and then restore it to 3.1.2, and jailbreak it?

    KEEP IN MIND:
    I have never jailbroken this phone before.
  2. #2  
    big9erfan's Avatar
    iMore Elite

    Posts
    2,468 Posts
    Global Posts
    2,470 Global Posts
    iOS Version
    6.0

    Default

    You're going to have to wait a bit longer.
    Twitter: @codemonkeycodes / website: www.codemonkeycodes.com &
    Married 9/4/11
    iPhone 6 64GB : ~= 5/10/10 RIP Dad, Forever in our hearts =~
  3. Thread AuthorThread Author   #3  
    ElectricDoodie's Avatar
    iPhone Newbie

    Posts
    48 Posts

    Default

    So, should I just upgrade to 3.1.3?

    Or stick with 3.1, hoping that something will come out?

    Also, would me going to 3.1.2 be a downgrade, since 3.1.3 is out? Or an upgrade, since I have 3.1?
  4. #4  
    LozBlanko's Avatar
    iPhone Newbie

    Posts
    17 Posts

    Default

    Seems to me that the only sensible option is to update to 3.1.3 and then patiently wait for a new rain to be issued. Could be a while though depending on what Apple has changed.

    Alternatively, search online to see if there's any way of upping to 3.1.2 still or downgrading from 3.1.3 to 3.1.2. I'm not aware of a way but there's far more techy people than me!
  5. Thread AuthorThread Author   #5  
    ElectricDoodie's Avatar
    iPhone Newbie

    Posts
    48 Posts

    Default

    Yeah, I think I'll just upgrade.

    And whenever I look online on how to downgrade from 3.1.3 to 3.1.2, all I get is people saying it's impossible, or that you need the SHSH file, which I don't have.

    And when I look for upgrades from 3.1 to 3.1.2, all I get is past articles about the "new upgrade" at the time.
  6. Thread AuthorThread Author   #6  
    ElectricDoodie's Avatar
    iPhone Newbie

    Posts
    48 Posts

    Default

    After doing some more research, I'll just hold on. I'd be an ***** to upgrade.
  7. #7  
    infohpreet's Avatar
    iPhone Nanite

    Posts
    6 Posts

    Default

    You should never upgrad to 3.1.3 unless you have complete information about jailbreak/unlock process of this os. As Apple is more cleaver this time.

    good luck!
  8. #8  
    infohpreet's Avatar
    iPhone Nanite

    Posts
    6 Posts

    Default

    But if you want to upgrade to 3.1.2 then you have to download the original firmware for 3.1.2. Do google search to get this firmware.

    Now connect your iPhone in recovery mode to PC and open iTunes.

    Here you will now see restore option.

    Now press the shift button and click the restore button.

    This will ask the .ipsw file for 3.1.2 and select that you have downloaded one.

    Please note that when you download ipsw file, it has .zip ext. you have to change its extension to .ipsw.

    good luck.

Posting Permissions