Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread AuthorThread Author   #1  
    devdhingra's Avatar
    iPhone Nanite

    1 Posts

    Default iphone wifi not working after blackra1n???

    I was trying to jailbreak my iPhone 3GS with blackra1n, but after following the steps provided in iClarified.com for the same, the blackra1n software restarted my iPhone, it wasn't able to connect with the wifi connection. I was able to see a blackra1n app on my iphone and on going inside it shows message “Please check your internet connection…” instead of other package options like Cydie/Rock. I don't know what to do now, it will be better if I can anyhow undo the jailbreak process and get back my previous settings on iPhone, which will unable me to connect wifi.

    I tried both option:

    1) Reseting the Network setting

    2) Getting the factory setting from iTunes

    But still the same wifi problem. When I manually go to my wifi under settings and click on my Home wifi network it ask for password same as in my laptop and after providing the correct password, it returns with an alert message “Unable to join myHomeNetwrok”. I am using Linksys WRT54GH (with speedburst) router and able to connect my laptop perfectly.

    Please suggest what to do now. THANKS
  2. #2  
    busnut44's Avatar
    iPhone Nanite

    3 Posts


    Did you find a solution to your problem? I'm having a similar problem. When I reset the network settings, my phone (3GS) reboots and I'm back in the restore mode.

    Any help would be appreciated.

Posting Permissions