Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    amg is offline
    amg's Avatar
    iPhone Newbie

    33 Posts

    Default AT&T showing up as carrier name, even when roaming

    DISCLAIMER - I searched already... so if there's an answer to my question already out there that I didn't find, sorry for not searching well enough!

    I am running 3.1.2 JB'ed with Blackra1n - When traveling out the country this past week, I noticed that my carrier name in the status bar always said AT&T whenever I had a signal - even if I was actually roaming on another carrier. (If I went into settings and looked at the network option, I could see the real carrier name).

    By contrast, my wife's 3.1.2 3GS that is not JB'ed showed the correct carrier name up top.

    Every search I've done on this issue led me to solutions for the NO carrier name problem that occurred with pwnage tool - that's a different issue.

    Is there a fix that anyone is aware of to get the phone to display the actual carrier rather than just static text (which is what I think blackra1n is doing to me) -


  2. #2  
    sargd66's Avatar
    iPhone Intermediate

    435 Posts
    Global Posts
    437 Global Posts


    Have you ever used fakecarrier or makeitmine? That could be your problem. If you uninststalled it reinstall it and reset the name and then reboot before you uninstall it again. That's the only answer I have. You will get more ideas from people I'm sure.
  3. #3  
    DrJB's Avatar
    iPhone Intermediate

    122 Posts


    If you are using TMobile don't sweat I called them about the same problem I was having and AT&T and TMob actually share the same towers and they said you shouldn't be charged if you happen to switch over in an area with no coverage by TMob

Posting Permissions