Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    stacychen's Avatar
    iPhone Newbie

    12 Posts
    Global Posts
    20 Global Posts

    Default iPhone has no sound... kind of

    My iPhone [removed link] is doing weird things this morning. I went to listen to a song while I was waking up and it wouldn't play on the external speakers! My alarm clock was working fine, and was very loud on the external speakers, but everything I've tried to play otherwise won't work. (I've tested the iPod and iTunes apps).

    I turned off the ringer and back on, when the volume icon comes onto the screen it says "headphones", even though no headphones are in. I turned the phone entirely off and back on again. That didn't help. I put in headphones and it works through the headphones! I took the headphones out again, and the speaker still won't work.

    Anything other suggestions of what this could be?? It seems stuck in headphone mode and I'm not quite sure how to get it out of that.
    Last edited by Leanna Lofte; 05-19-2009 at 11:16 PM. Reason: removed advertising link
  2. #2  
    Ghecko's Avatar
    iPhone Intermediate

    202 Posts
    Global Posts
    203 Global Posts


    Ehhh you would have to restore fresh not from back up fresh..... if that still does not work then it might be a faulty sound card.

    Or better yet.
    get some canned air from office deopt and spray it down the head phone jack there might be something lodged inside.
  3. #3  
    hermdog's Avatar
    iMore Intermediate

    481 Posts
    Global Posts
    494 Global Posts


    I had this happen yesterday and I held the power button and the home button until my iPhone rebooted and the issue went away.

Posting Permissions