Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread AuthorThread Author   #1  
    phlows's Avatar
    iPhone Nanite

    1 Posts

    Default iPhone 2.2.1 jailbreak failure or unapproved PAYG sim?

    So today I stepped up and bought a used iPhone 3g 16G (model A1241). I bought it for use with my already activated at&t "pick your plan" SIM - which I read works with the iPhone here:

    Before selling me the iPhone, the guy did a restore on it (today 2/11/09), which I'm assuming means that it was upgraded to 2.2.1?

    I tried to follow the steps on this post:

    I was able to get it flashed to 2.2 succesfully if I unchecked the "Activate the phone" checkbox in PwnageTool. But when I start my phone I still get the dreaded "emergency only" calling screen. When I click the "Activate the phone" checkbox and try to flash it.. I get an error.

    I'm using an at&t "pick your plan" sim card. I have read numerous reports that these sim cards work with the new iphone 3g's "out of the box". So what is going on here? Is at&t not accepting my sim card because its "pick your plan" ? And I'm unable to unlock it because the guy I bought it from upgraded to 2.2.1? If I call at&t will they be able to activate my iPhone with my PAYG sim?

    Please help, your comments and suggestions are very appreciated.
  2. #2  
    jamesus's Avatar
    TiPb Forum Staff

    1,839 Posts
    Global Posts
    1,898 Global Posts


    If a full restore was completed, then baseband 2.30 was installed on it, which doesn't allow for the phone to be unlocked. PAYG sim might work on unlocked iPhones and might not work with unlocked iPhones. You might need confirmation from AT&T that PAYG sim card works with iPhone.

Posting Permissions