1. MikeElmendorf's Avatar
    Somehow several years back, I ended up with a second, similarly named iTunes account. So, I have music purchased under both accounts.

    Both are authorized on my computer, and content from each played fine on my iPhone 6S and iPad Air 2.

    I replaced both this week with a new iPhone 7 and iPad Pro.

    The problem is, music from the second account (not the one I stay logged into and purchase from now) will NOT play on either device. When I select content from that account, it asked initially for the login info and password for iTunes. After entering it the first time, it just asks for the password. But, even after entering it, it still doesn't work. It shows the EQ bars next to the song icon like it is going to play, but then just goes to another song. Same behavior on iPad and iPhone.

    To confirm this wasn't an iOS 10 thing (both prior devices had been updated), I checked and verified that all content played correctly on the old devices.

    I've tried logging out of iTunes on my primary account and back in with the secondary, old account, and it still does not work.

    This is very frustrating problem and has me without access to a big chunk of my library.

    Help, please!
    09-18-2016 09:04 AM
  2. MikeElmendorf's Avatar
    Well, I seem to have solved my own problem. You need to sync with iTunes while signed into the other account. This a change from before, when simply entering the password on the device worked.
    Tartarus and quicksilver53 like this.
    09-18-2016 09:21 AM

Similar Threads

  1. Post pics taken by iPhone 7
    By Ravanelli in forum iPhone 7
    Replies: 154
    Last Post: 05-15-2017, 05:54 AM
  2. Early Shipment from Apple!
    By metsgoon in forum iPhone 7 Plus
    Replies: 56
    Last Post: 09-23-2016, 05:14 AM
  3. Replies: 12
    Last Post: 09-21-2016, 10:57 AM
  4. Can you lock apps on an IPad?
    By yolandaw in forum iPad 2
    Replies: 1
    Last Post: 09-18-2016, 10:44 AM
  5. Replies: 1
    Last Post: 09-18-2016, 08:10 AM
LINK TO POST COPIED TO CLIPBOARD