Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread AuthorThread Author   #1  
    jGoff#IM's Avatar
    iPhone Nanite

    1 Posts

    Default How to turn off itunes auto start for IPAD & PC

    Sorry if this has been discussed before, but I could not find it.
    I'm running iTunes 10.3.1 on a Windows 7 Pro and have a IPAD2 4.3.3 (JB).
    I mistakenly said yes when asked if it was okay to autostart iTunes when my IPAD was plugged into the USB port. Now I want it to stop.

    1. On the summary tab options:
    "Open iTunes when this iPad is co..." is unchecked & greyed out

    2. Edit/Preferences/Devices:
    "Prevent Ipad from syncing automatically" is checked

    3. I would rather not set the "Apple Mobile Device" service to "Manual" because other programs besides iTunes use it.

    It does not seem like this should be so difficult, but it is.

    Anyone have a cure?


  2. #2  
    hggs's Avatar
    iPhone Newbie

    34 Posts


    I don't have a copy of Windows close to test it but I found this in another forum:

    The macosxhints Forums - View Single Post - How to prevent iTunes from opening when iPhone connected

    ah, there seems to be a problem in Apple's implementation

    Yes, I disabled iTunes menu: Preferences: Devices: "Disable automatic syncing for iPhones and iPods"

    Unfortunately, the Preferences setting disables the iTunes Summary "Automatically sync [this device] when connected" setting for the connected device.

    The iTunes Summary setting is grayed out and cannot be changed. (The checkbox is unchecked.) iTunes nevertheless auto-launches when the device is connected.

    However, there is a workaround solution:

    Allowing auto-syncing for all devices in Preferences, and then turning automatic syncing off for the device in Summary, corrects the problem and prevents iTunes from auto-launching when the device is connected.

    Thanks for helping to pinpoint the problem here, it was an Apple bug and not documented anywhere I could find.
    Hope it helps.

Posting Permissions