Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    nickgoodman1's Avatar
    iPhone Nanite

    1 Posts

    Default Itunes 9.2 for IPhone4

    I have my IPhone 4 but cannot connect up to my Mac at home - I pug it in and get the message 'The iPhone cannot be used because it needs ITunes version 9.2 or later. I have downloaded it (Plus it is definitely already on my Mac) but still get the message. i cannot find out where to check on the phone exactly which version it has installed - any ideas? Thanks
  2. #2  
    Duvi's Avatar
    iMore Elite

    2,044 Posts
    Global Posts
    20,036 Global Posts


    Reboot both phone and mac. Also switch to the
    next USB port.
  3. #3  
    OTACORB's Avatar
    iMore Pro

    659 Posts
    Global Posts
    730 Global Posts


    You may end up having to just uninstall iTunes and then reinstall it. I would do that if it continues beyond anything else you've tried.

Tags for this Thread

Posting Permissions