Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    angelavs's Avatar
    iPhone Nanite

    1 Posts
    Global Posts
    5 Global Posts

    Default iOS 4.3 question for older iTouch

    I have an older iTouch, I'm not sure which however, it was the one they came out with just before making the ones with cameras.

    Anyway, I'm trying to download certain games and I keep getting an error message saying "Update Required, this app requires iOS 4.3". I'm pretty sure my updates are current.

    Is there a way to make these games run? Find this update? or should I just break down and get a newer one?

    Thanks for any advice or suggestions.
  2. #2  
    pkcable's Avatar
    Q&A Jedi

    3,344 Posts
    Global Posts
    38,327 Global Posts


    Sounds like you have a 3rd Gen, that's the last one without the camera. Well actually the 4th Gen is the only 1 WITH a camera, and is the current generation. You should be able to update your ipod touch to the latest 5.1.1 firmware via itunes.
  3. #3  
    Hassan Bardin's Avatar
    iPhone Nanite

    1 Posts

    Default Re: iOS 4.3 question for older iTouch

    Ios4.3 me permite pas d'installer des applications sur mon iphone

Posting Permissions