Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread AuthorThread Author   #1  
    insprion23's Avatar
    iPhone Nanite

    1 Posts
    Global Posts
    4 Global Posts

    Default 2g Ipod touch restores, but doesnt boot.

    I have an 8GB 2g ipod touch that i've been trying to fix for a few days now. When I restore it, it goes through the process, loads into itunes. lets me set up a new device and put on songs. But it never boots up. It does all that with the white apple logo. I have tried 3 different computers, to see if that's not the problem. I have also tried a few different and older firmwares but it does the same thing over again. I tried all this in DFU mode.

    Also every time I set it up, it automatically makes a backup and restores it, Who knows why.

    Any Help would be greatly appreciated.
  2. #2  
    Ipheuria's Avatar
    iMore Genius

    7,265 Posts
    Global Posts
    7,332 Global Posts


    I would say take it to an Apple store if you've tried all sorts of different scenarios it might be a hardware problem.

Posting Permissions